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0 Overview



WinDisp is a geophysical map generation program licensed to RioTinto. The program runs under all versions of Windows and produces maps at scale for a variety of input data sources. The specific purpose of this document is to describe how WinDisp can be used to generate dipole-dipole IP pseudosections, plot the pseudosections, generate files required by the UBC IP inversion code, how to run the inversion and how to display the results of the inversion.



The simplest method for using WinDisp to display IP data is to select the IP Dipole-dipole Data option from the opening display option window pictured below



�



�1 Automatic Generation of IP Pseudosections



Once this option is selected and the OK button is clicked, the program prompts the user to select the data file containing the IP data. Once a data file has been selected, the contents of the file are displayed as shown below so that the user can ascertain that the correct file has been selected.



�





If you do not wish to proceed with the selected file, click on the Cancel button and you will be returned to the opening Display Option menu. If you wish to proceed with processing the data contained in the file, click on the Continue button and WinDisp will attempt to determine the format of the data contained in the file. The current implementation of WinDisp (Version 2.75) automatically recognises and decodes Zonge avg files, Geosoft dat files and files output by the separate dipole program for Scintrex dmp files and gives the user the option of automatically including resistivity and chargeability fields with standard defaults for gridding, contouring and display. If the selected file is not in one of these formats, but has a simple columnar structure containing plot point, n level (or depth), resistivity and chargeability data (as a minimum), the file can still be processed, but WinDisp will prompt you to identify which columns contain which data fields.





�1.1 Zonge avg Files



After clicking on the Continue button, WinDisp decodes the a spacing from the second line of the file and determines which columns contain the plot point, n level, resistivity and chargeability data from the third line. In addition the %Rho and sPhz columns are identified for use in the generation of the UBC IP inversion files. If any of these steps fails, WinDisp will switch to the standard column mode format determination.



Once the resistivity and chargeability fields have been decoded, the user is presented with the following input screen to permit the modification of how the resistivity and chargeability are to be displayed and also for the selection of further data columns to display in pseudosections format. 



�



To modify the display options for any currently defined data columns, click on the drop-down list in the lower-left hand frame and select the required data column name. Once the name is selected, the current display options for that variable are displayed and can be modified appropriately:



�





Note that for the resistivity field displayed above, the column name in the data file (Resistivity) has been automatically converted to Apparent Resistivity (obs) (ohm.metres). If this name is not acceptable, it can be changed using the Title Name text box.  



The first option available on this frame is to delete the data variable. Clicking on this button removes the currently selected data variable from the list of data to display in the generated psuedosection. 



The main item in this frame which controls the location of the panel for this data variable is the Column Number item. This value specifies which horizontal column the data variable will be displayed in. These columns are ordered from left to right starting at 1. Within each column the panels are displayed in order from top to bottom.



The next main option is the Generate Image File check box. If this is turned off, no other options are relevant and the current data variable will simply be posted in the pseudosection. If the Generate Image File check box is turned on, the current data variable will be gridded and the image will be displayed in the pseudosection along with the posted data. When the data is gridded, a positivity constraint can be imposed (as is appropriate for resistivity) by clicking on the Maintain Positivty  in Image check box. When this box is selected, the data is read from the file, the natural log of the data is then gridded, and the exponential of the gridded data values written to the image file.



The way in which the image is displayed can be further modified using the Image Colour Table specification. By clicking on the small button with three dots or double-clicking in the Image Colour Table text box, an existing colour table file can be selected. Clicking on the radio button then specifies that this file should be used for displaying the image file for this data variable. The colour table specifies the data range and data histogram which is to be used for converting data values in the image file to colours in the displayed image. Once such a file has been constructed it can then be used to ensure that a particular data field is displayed consistently for all data lines in a survey to enable simpler comparisons between the psuedosections for different lines. If no colour table is to be used, the data range can still be used to provide a basis for comparing different lines by specifying the minimum and maximum histogram limits in the Histogram From and To text boxes. If the radio button for the Histogram limits is turned on, the histogram is calculated from the data in the image file clipped to the specified limits. This can be useful for excluding extreme outliers in the data range, or to highlight variations within a range of particular interest. It needs to be kept in mind that images from different lines displayed using this option cannot be directly compared because the histogram distributions for the different lines will be different, so colours in one image will not be directly related to colours in the other (except for the minimum and maximum values).



The use of the data distribution to generate a histogram for determining display colour can be controlled using the Histogram Equalise Image check box. Turning this off specifies that colours should be allocated linearly between the minimum and maximum data value. When this option is turned on (the default), the histogram of the data in the image is calculated and colour allocated to data ranges to give an equal area of each colour in the displayed image.



The final option available for displaying the image is the Invert Colours in Image check-box. Turning on this check box specifies that the image will be displayed using colours in the reverse order from usual ie red for low to blue for high. This is the default option for resistivity so that the image will be coloured as though it was conductivity.



The next set of options specifies the generation of contours and their appearance. Checking the Generate Contour File check-box, specifies that the image file will be contoured and written to a file with the same name as the image file (with the extension con instead of grd). When the contours are generated, they can be distributed in linear ranges using the data histogram or generated from a standard multiplicitave list. The multiplicative list is the default for resistivity and the linear ranges is the default for conductivity. Further to these options, the labelling interval for the contours can be  specified in the Contour Label Interval text box.



�1.2 Geosoft dat files



After clicking on the Continue button, WinDisp decodes the a spacing and line number from the second line of the file and determines which columns contain the transmitter dipole coordinates (C1 C2), the receiver dipole coordinates (P1 P2), resistivity and chargeability data from the third line. If any of these steps fails, WinDisp will switch to the standard column mode format determination.





�



Once the Continue button has been clicked, the default specifications for are applied to resistivity and chargeability fields (if this option has not been turned off), and the data column specification form displayed in the Zonge section above is displayed.







�1.3 Dipole utility output files



After clicking on the Continue button, WinDisp requests the user to enter the a spacing and then determines which columns contain the plot point, n level, resistivity and chargeability data from the data column identifiers on third line. If any of these steps fails, WinDisp will switch to the standard column mode format determination.





�

 

Once the column names have been determined from the file, the user is then prompted to enter the a spacing  for the data:





�



Once this information has been supplied, the default specifications for are applied to resistivity and chargeability fields (if this option has not been turned off), and the data column specification form displayed in the Zonge section above is displayed.

�1.4 Column mode format files





�



Any failure to read files of the above format or any files which do not have the above structure will result in WinDisp starting column mode format decoding of the file. The first piece of information WinDisp requires to read the data from the file is the line number at which the data begins in the file.





�

 

The line number entered should be the line containing the column header names if one exists in the file, or the line on which the data actually begins in the data file. Clicking on the Cancel button returns the program to the initial Display Options menu. If the OK button is clicked, WinDisp will read the specified line from the data file and attempt to read the data names from the line. If character names are found, these will be used to refer to the data columns in subsequent prompts. If only data values are found, the data columns will be referred to by number (eg depth in the above file would be column 3).





�

Once the column names have been determined from the file, the user is then prompted to enter the a spacing  for the data. 

Next the user is asked to select the name of the column to use as the x (or along line) coordinate. The x axis variable name is selected by clicking on the x variable drop-down box, clicking on the name of the variable to use (in this case NTH) and then clicking on the Next Coordinate button. Clicking on the Cancel or Done button at this stage returns the program to the initial Display Options menu.





�



After selecting the x axis variable, the user is then prompted to select the y axis or depth variable.





�



Clicking on the Add a Variable button at this stage takes the user to the Data Variable definition form displayed in the Zonge section but as the resistivity and chargeability variables are not automatically determined from the file, the user will be defining data variable 1 rather than 3 as in the standard case. For this type of data file, the user will need to first specify the resistivity data field and define the image generation and contour specifications. Once these have been defined, click on the Add a Variable button and define the Chargeability data field in the same fashion.





�1.5 Displaying Optional Extra Data Fields



Once the above steps have been completed successfully WinDisp has enough information to generate a basic pseudosection from the data file supplied. Before proceeding to do this, WinDisp first allows the user to add extra optional data fields from the data file to the pseudosection. The input dialogue box has the form illustrated in the Zonge data file section above.  





�



To select a data field to add to the pseudosection click on the drop-down box in the right lower frame, select the name of the variable to use and then specify the data type of this data column (resistivity, chargeability or other) data. Once this is done, the image and contour display options can be modified.



Once any extra data fields have been specified, clicking on the Done button initiates the processing sequence. Clicking on the Cancel button returns the program to the initial Display Options menu.



1.6 Pseudosection Processing Sequence



Once the format of the data file has been decoded or defined and the data fields selected, WinDisp proceeds to read the IP data from the file and determines the area limits for the data read. For Zonge complex resistivity files, only the decoupled data (ie for 0Hz) is read from the file and for the dipole utility output only the first line of data is processed.



Once the data is read WinDisp prompts the user to enter the target map scale for displaying the pseudosection. The user is presented with a default value for the map scale, but this default can be changed to any value required by the user.



After the IP data has been read and the map scale defined, the resistivity data is gridded using the a spacing/10 as the cell size and the a spacing as the search radius. Also the gridding is performed using the natural log of the resistivity data and then the exponential of gridded data is written to the grid file (unless the Maintain Positivity in Image check box has been turned off). This maintains the positivity of the resistivity data. After the resistivity data is gridded the grid file is contoured using the multiplicative sequence 1, 1.5, 2.5, 4, 6.5, 10 (if the contour list is set as Multiplicative).



If the gridding and contouring of the resistivity data is successful, WinDisp then proceeds to grid and contour the chargeability data. This data is gridded using the same cell size and search radius as for the resistivity data. Once the grid file has been generated, by default the chargeability is contoured using a constant interval (chosen as a multiple of 1, 2.5 or 5) so that there will be between 10 and 20 contour levels.



If any optional extra data fields were defined, these data fields are then gridded and contoured using the same specifications provided by the user.



Once all data fields have been successfully gridded and contoured the completed pseudosection is then displayed in the graphics window as in the example below.



�	



�2 Saving the layout specification



WinDisp allows the user to save the specifications defining the current map layout for future use and modification. By default the specifications used to generate the displayed pseudosections are saved using the same name as the specified data file but with the extension csf. To save the specifications using a different file name click on the File menu item and then click on the Save As…  item to bring up the file save dialogue box. Select the location and name you wish to give this layout specification (the extension csf will automatically be added if no extension is supplied) and WinDisp will save the current layout definition to the specified file. If you forget to save the specifications (or WinDisp crashes) the specifications of the last layout displayed are saved in the file current.csf in the working directory. This can be opened and the layout redisplayed or printed.



3 Interacting with the display



A full description of the options available for interacting with the display are available in the on-line help and the user is advised to use the help to make best use of these options. 



As a quick guide the Display! menu item is used to draw the currently defined map layout. Once a layout is displayed the menu system can be used to bring a variety of forms which can be used to modify the layout. WinDisp does not automatically redraw the display to reflect any changes to the layout made in this way by the user, though depending on the severity of the change, the Print option may be disabled or the user prompted to regenerate the layout before printing proceeds.



To zoom in on a region of the layout of particular interest simply click and hold the left mouse button at one corner of the region, drag the mouse to the opposite corner (a rubber-band box will be displayed while the mouse is being dragged) and release the mouse button when the desired region is selected.



To pan across the current displayed layout, simply click with the right mouse button anywhere in the current display. The layout will then be redisplayed at the currently displayed scale with the centre of the new region located at the point the mouse button was clicked.

 

To zoom out from the current display, select the Zoom > Zoom Out menu item and displayed region of the layout will be enlarged by a factor of two centred on the centre of the currently displayed region. 



To redisplay the current layout at full size either double-click anywhere in the graphics window with the left mouse button or use the Zoom > Plot Extents menu item.



The current graphics display process can be interrupted any time the status box in the lower left-hand corner of the window is red by clicking on the status box. If the box is black it indicates that WinDisp is calling a system function and cannot be interrupted. A green box indicates that WinDisp is in between individual processing steps or is not currently doing anything.



�4 Printing the Layout



The currently defined layout can be printed using the File > Print menu item (ie click on File and then Print). Clicking on the Print menu item brings up the Print Options form:





�





There are a variety of options for printing the display available from here. These options are described in detail in the on-line help, so will not be described here. The main things to note are that the layout can be plotted directly to a printer using either the default Windows printer (the printer and its properties can be changed using the Select Printer button) or can be sent to file using either PostScript, HPGL/RTL, DXF or Windows Metafile format. The first two file format support full image output, DXF does not support image output and the current Metafile output does support images but the current implementation does not correctly register the colour palette so the image does not display correctly (hopefully this will be fixed in the near future). 



If the current layout is too large for the available printer, the user can either click on the Fit plot to page option or try the Rotate Plot option, or print the layout as it is using the panelled layout depicted on the Print Options form. If the user selects the Fit plot to page option, WinDisp will calculate the scale factor required to shrink the layout to fit the current page. NB this option does not change the map scale used to generate the layout, it simply shrinks the current layout so that it fits on the current printer page. The user can also specify a specific Reduction Factor for the Fit Plot To Page option if required.





�5 Modifying the IP layout : Map scale and area limits

 

There are a variety of options for modifying the simple IP pseudosection layout as generated above. The simplest is to change the area limits or scale of the layout. To do this click on the Edit  > Area Limits, Scale and Projection menu item to bring up the following form:



�



The main options of relevance here are the minimum and maximum eastings and northings and the plot scale items. The plot scale defines how data coordinates are converted to paper coordinates and the area limits define the limits of the region to be displayed in each of the panels displayed in the IP plot layout. The Projection and Geographic Limits are not relevant to IP layouts and no changes should be made to the default values.





�6 Modifying the IP layout : Frame, Border and Colour Legend



Once the map scale and area limits are specified, the next step to modifying the IP map layout is through the Edit > Frame, Border and Colour Legend menu item. Clicking on this menu item brings up the form below. All of the items except the Longitude, Latitude and Colour Legend tabs are of relevance to IP layouts. Once again most of these options are described in the on-line help so will not be detailed here.



�



The Eastings and Northings tabs allow the user to modify how the easting and northing axes are displayed and labelled and how tick marks and graticules crosses and or lines are drawn. 

 

The Frame tab allows the user to specify a line of text to display across the top of the layout the size and location of the Legend Box, the spacing between the outer frame and the easting and northing axes and the size of text to use in the Legend Box. 



The Edit Title Block button allows the user to specify the text which will be displayed in the Title Block.



The Legend and Scale tab allows the user to control which of the map scale bar , colour scale bar and colour legend should be displayed and their lengths. An optional logo file can also be specified on this tab.



The Processing Legend tab allows the user to add optional text to the layout. This legend can be used to describe the collection parameters for the data or processing details or any other information. Clicking on this tab displays the following information:



The Clear Text button clears any currently loaded processing text. 



The Load Text button brings up a file selection dialogue box which can be used to select a file to load into the processing legend. 



The Text size item defines the size of text used in displaying the processing legend.



The Draw Border check box determines whether the processing legend is displayed within a surrounding border.



The Inside Margin item defines the distance between the border (whether displayed or not) and the text displayed. The Outside Margin defines the distance between the border (whether displayed or not) and the left-hand side limits of the area used for displaying the legend information.





�





�7 Modifying the IP layout : Specifying Data Names and null values



The next Edit item of direct relevance to the IP layout is the Edit > Posting > Specify Data Names menu item. Clicking on this menu item brings up the following form:



�



This form can be used to change the name associated with a column of data read from the data file and the null-data value used to determine valid data values. 



The first column on this form displays the column number of each data column in the current data file. 



The next column identifies the name by which WinDisp identifies this data column (usually the same as the column number) and cannot be modified. 



The third column displays a sample data value as read from the data file. The first 64 lines from the data file as decoded using the current format can be displayed by clicking on the Next/Previous sample buttons at the lower left corner of this form. 



The fourth column displays the column names as they are presented to the user for identifying the data columns to use for coordinates and posted values. These data names are derived from the data file and/or the file decoding process. To change a name simply click on the name which is to be changed to bring up an editable text box, change the text as desired and click outside the box to save the changes.



The fifth column displays the current value used by WinDisp as the no-data value for that data column. This value can be changed in the same way as the user defined name.



The final column allows the contents of individual data columns to be identified as real, integer or character fields. For IP layouts only real data fields can be displayed.



Once any desired changes have been made, this form can be dismissed by clicking on the Done button. Clicking on the Cancel button discards any changes made on this form and closes the form.



8 Modifying the IP layout : Posting Specifications



The principal menu for modifying the IP layout is the Edit > Posting > Edit Posting Specifications menu item. Clicking on this menu item brings up the following form:



�







8.1 Data Posting Specifications Menu



Once again the full description of the operation of this form is contained in the on-line help, so only those aspects of particular relevance to the IP layout will be discussed here.



Starting from the top of this from, the Data Posting File text box displays the name of the data file containing the IP data. This file cannot be changed from this form and the file name is displayed for information purposes only. To change the data file, you need to exit this form and use the Edit > Posting > Select Posting File menu item.



The View File button allows you to view the first 64 lines of the specified data file. Clicking on this button brings up a scrolling text box on a separate form. When you have finished viewing the contents of the file click on the Done button to return to the standard Data Posting Specifications form.



The Posting Style drop-down list box allows for the posting style to be changed, but there is no other posting style of relevance to IP data files, so the posting style should not be changed.



The Repeats Policy drop-down list specifies how repeated readings will be treated by WinDisp when displaying an IP layout. The choices available are:



None : all readings are posted in the display, the first reading is displayed directly to the left of the posting point, the next repeat is posted directly beneath the first and so on. Note that this form is not suitable for generating UBC inversion files.



Mean : all readings for each posting point are read from the file and the average value posted on the layout directly to the right of the posting location

 

Median : all readings for each posting point are read from the file and the median value is posted on the layout directly to the right of the posting location

 

Min : all readings for each posting point are read from the file and the minimum value posted on the layout directly to the right of the posting location

 

Max : all readings for each posting point are read from the file and the maximum value posted on the layout directly to the right of the posting location

 

First : all readings for each posting point are read from the file and the first value posted on the layout directly to the right of the posting location

 

Last : all readings for each posting point are read from the file and the final value posted on the layout directly to the right of the posting location

 

The Sample Marker Number is the index of the marker which is drawn at the posting location. The index number can be increased or decreased using the spin control at the left-hand side of the text box. Alternatively clicking once on the text box itself will bring up a menu displaying the available markers from which the desired marker can be selected.



The Size of Marker specifies the size at which the marker will be displayed in the layout. Setting the size to zero results in no marker being displayed.



The Posting Angle field specifies the angle in degrees at which the data posting will be displayed. Thus value affects all elements of the displayed values including the posting marker and posted text.



The Use Colour Ranges check box is not generally applicable to IP posting, but if selected permits the text colour of the posted value to be determined by reference to the colour legend range on the Edit > Frame menu item.



The Dipole Length item specifies the dipole length used in converting n levels to/from depth. 



The Panel Separation item specifies the space left  between one panel in the IP pseudosection layout and the panel immediately below it.



The scrolling grid box containing the Name of Data Variable and Posting Column specify which data values are posted and which column the data value will be posted. Extra data values can be added to the display by scrolling down the list to locate an empty row, clicking in that row in the Name of Data Variable and selecting the required data variable from the drop-down list that will be displayed. Changing a data variable is achieved in the same fashion, simply click on the data variable name to be changed and select the new data variable name. To change the Posting column click on the value which is to be changed and enter the new value in the edit box which is displayed. The Posting Column determines which column within the layout that the data value will be posted. The width of these columns is determined by the easting limits, map scale and y axis margins. The data values are posted consecutively in order within these columns starting from the top of the layout. The specified columns do not have to be consecutive.



In addition to adding and changing data variables, you can also delete, move and copy the posting definitions of individual data variables. To delete a data variable from the displayed list scroll the list until the desired data variable is in view, highlight the data variable to be deleted by clicking on the row number in the grey box at the left-hand side and delete it by pressing the delete key. To copy the deleted data variable to another location in the list, scroll to and highlight the row where the data variable is to be inserted, and press the insert key. Once a variable has been deleted, its posting definitions are retained until a new layout is started or loaded or another data variable is deleted. Thus the deleted data variable can be used as a template for adding extra data variable to the posting list by setting the first data variable up with the desired definitions, deleting it and then inserting it into the list the desired number of times and finally changing the data variable names to the required quantities.



Menu Items



This form also has three menu items defined:



Options > Clear Saved Data clears any currently saved version of the posting data file. When posting data, WinDisp reads all data from the current data file using the current specifications and stores it in a temporary binary file for faster access. If you have identified and fixed an error in the data file you can force WinDisp to re-read the data file by clicking on this button.



Options > Clip Data to Area Limits enables or disables clipping of the data read from the file using the current layout area limits. When this option is turned on WinDisp stores only those points within the currently defined limits in the temporary binary data file. Turning this option off forces WinDisp to store all data read in the temporary file. This latter option is useful for determining the full limits of the data contained in the data file so that the layout area limits can be changed to include all data.



Options > Mask Label enables or disables the use of a white background box for posted data values. When this option is turned on, the text background is set to white so that any image and/or contours beneath the label will be masked out and the posted data value will be easier to read. 



UBC Output - this menu item will be discussed in the section on generating UBC IP inversion files.



Command Buttons



The Cancel button discards any changes made on this form and exits from this form. Clicking on Done commits the changes before exiting the form.



The Export Data button exports the current data as a csv file suitable for use in Excel or other applications. Clicking on the button prompts the user to select the location and name of the csv file and then writes the data to the file. For IP data the output file will contain the line number (if one is specified), the plot point, depth and each of the selected data variables each separated by a comma. Additionally the first line will contain the  names of each of the data variable output.



�8.2 File Coordinates Menu



The Define Data Coordinates button brings up the menu displayed below.



This menu allows the user to select between the plot point/n level definition used in Zonge avg file and the C1 C2 P1 P2 source/receiver definition used in Geosoft files. Also a line variable can be selected here to select an individual line from a multiple line file. For example in a Zonge complex resistivity file this form will have Freq specified as the Line variable and o as the Minimum and Maximum value. In this case changing both minimum and maximum to 0.125 will display the first harmonic data instead of the decoupled data.



Clicking on Cancel on the File Coordinate Definition form cancels all changes and returns to the Posting Specification form. Clicking on Done commits the changes before returning.



�



�8.3 Post Variable Definitions Menu



The Define Data Variable button brings up a menu from which the posting parameters affecting the currently highlighted data variable. To highlight a particular data variable simply click on the data variable name or anywhere in the particular row.



�





At the top of this form the currently selected data variable name is displayed for information purposes only. Once in this form the selected data variable can be changed by using the drop-down list in the bottom left-hand corner of the form to select any other currently defined data variable (Note this list will not be displayed if there is only one data variable).



Immediately beneath the data variable name are the X offset and Y offset items.  These offsets specify the distance in mm that the posted label will be moved from the standard posting location. This standard location is immediately to the right of the posting marker displayed at the post location.



The next item is the Label Size which specifies the text size in cm to be used for posting the current data variable



The Label Interval specifies the distance between consecutive labels along the x axis direction is user data coordinate units. If this value is set to zero, WinDisp will automatically select an approropriate labelling interval.



The Number of Decimals item specifies how many digits after the decimal point are to be displayed in the posted data value (eg 99.655 will be posted as 100 if Number of decimals is set to 0 and 99.7 if it is set to 1)



The Label Rotation field species the rotation of the individual posted text for the current data variable.



The Text Colour box displays the text colour to be used to display the currently selected data variable. The default is to use black text. To change the text colour click once on the Text Colour box to bring up the colour dialogue form. This form displays the current definitions of the 16 colour pens available. If one of these colours is acceptable, simply click on the desired colour and click on Done. If none of the colours is what you want double click on the colour box of the pen number you wish to redefined to bring up the custom colour dialogue form, specify the desired colour, click on Done to return the Pen Selection form and click on Done again to return to the posting form.



The Set UBC Output Options button is used to bring up data variable definitions specific to generating the files required for UBC IP inversion and will be discussed in the UBC IP Inversion section below.



The remainder of the form specifies the image, contour and dxf files to be displayed in the panel associated with the currently selected data variable. This information is automatically filled in by the IP pseudosection generation code, but can be manually changed by the user to suit individual requirements.



The Image File portion of the form allows the user to select an image file to display in the relevant pseudosection panel and to control how the image is displayed. The check box on the left-hand side allows to turn the image off without deleting the image file from the layout. (This effect can also be performed globally by unchecking the Edit > Display List > Images menu item). 



The image file to be displayed can be changed by either clicking on the small button to the right of the file name box or by double-clicking on the file name box itself. This brings up a standard file selection dialogue from which the location and file name of the required image file can be selected.



The File Format drop-down list specifies the format of the file to be displayed. This can be changed by the user, but is mainly for information purposes since WinDisp automatically determines the image file format itself. (Note all files generated by the automatic IP display are Geosoft Binary files)



The Image Style drop-down list allows the user to change the colour scheme used to display the selected image files. The main choices of relevance to IP displays are Colour (the default) and Grey Scale. Real-time and Colour draped sun-illumination options should not be used.



The Invert Colours check box allows the user to reverse to order of the colour palette so that red (or white for Grey Scale) is used for low data values and blue (or black) is used for large data values. This can be used to make resistivity look like conductivity (or vice versa) for those users that prefer to see conductivity in their pseudosections.



The Histogram Equalise check box allows the user to turn off histogram equalisation of the image display. The default is for histogram equalisation to be turned on and in this mode an equal area histogram stretch is applied to the data values in the image file so that the displayed image has approximately equal areas associated with each colour in the palette. If histogram equalisation is turned off, the data values for pixels in the image are assigned linearly to the colour palette.



Also affecting the way in which the image is displayed is the Colour Table File. When histogram equalisation is turned on and a colour table file is specified, the histogram used for assigning colours to pixel values is read from the specified file instead of being generated from the image file itself. This option is provided so that pseudosections for multiple lines within the same survey can be displayed using a consistent correspondence between colour and value to permit easier comparison between different lines. The colour table file (with file name the same as the image file but with the extension hst) is automatically generated by WinDisp when the image is displayed. Once a specific image file has been chosen as being the most suitable reference image, simply load the histogram file for that image file into the colour table file for all other IP layout and the same data range and histogram will be used. Other techniques for modifying the histogram are available using the Edit Image button to bring up the Edit Image menu form and these are detailed in the on-line help.



The Contour File portion of the form allows the user to select and/or generate a contour file to display in the relevant pseudosection panel and to control how the contours will be displayed. The check box on the left-hand side allows to turn the contours off without deleting the contour file from the layout. (This effect can also be performed globally by unchecking the Edit > Display List > Contours menu item). 



The contour file to be displayed can be changed by either clicking on the small button to the right of the file name box or by double-clicking on the file name box itself. This brings up a standard file selection dialogue from which the location and file name of the required contour file can be selected.

If an image file has been selected for which there is no current contour file, the contours for the file can be generated by clicking on the Generate Contours button. This brings up a separate menu on which the desired contours can be automatically generated from the image histogram and modified by the user. Contours can be generated using up to eight min, max, increment triples or using up to eight values in a multiplier list to generate a logarithmic spacing of contours.



The way in which contours are selected from the contour file and how they are displayed is controlled using the contour list file. This can be changed by either clicking on the small button to the right of the file name box or by double-clicking on the file name box itself. This brings up a standard file selection dialogue from which the location and file name of the required contour list file can be selected.



To change the currently defined contour list click on the Edit Contour List button to bring up the Edit Contours menu. This menu allows the user to change which contours will be displayed, the colour used to display them, the density at which they will be displayed and labelled. A complete description of the use of this menu is available in the on-line help.



The DXF File portion of the form allows the user to select a DXF drawing file to display in the relevant pseudosection panel. The check box on the left-hand side allows to turn the DXF display off without deleting the DXF file from the layout.

�8.4 Post Data Details Menu



The Display Data Range button on this menu has exactly the same function as the button with the same label on the Posting Specification Menu. Clicking on this button causes all data to be read from the IP data file (if this has not already happened) and a histogram of the data distribution to be generated. This is displayed as follows:
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This form performs the multiple functions of displaying some simple statistical information on the currently selected data variable (which can be changed using the drop-down list in the bottom left-hand corner of the form) and also provides an interface for generating grid files from the posted data values. The grid files are automatically generated by the initial IP pseudosection layout process, but if extra data variables are added to the display, then the grid files for these data values need to be generated manually.



�8.5 Gridding Options Menu



To grid the current data variable specify the grid cell sizes and search radius in the appropriate boxes at the top of the form. For IP data the recommended values are a cell size of 1/10 of the dipole length and a search radius equal to the dipole length.   Next specify a name for the output grid file and a grid file format (in the current version this has to be Geosoft Binary for the default MINC routine). Next click on the Display Grid Options button to show the available options for gridding. This changes the form to the following display:
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The Grid ln of value option can be used to maintain positivity of the generated grid file by transformaing the data values using the natural log and taking the exponentia of the resukting gridded data values. 



The Grid All Data Fields check box specifies that a grid files should be generated for each defined data variable. Selecting this check box changes the grid options frame to the following:
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This displays the output file for each field to be specified (the default name is formed by appending the first two letters from the data variable name to the first six letters of the output file base name). Also the gridding of individual data fields can be controlled using the Grid Field check box. 



The standard gridding algorithm used by WinDisp is the USGS MINC program. This algorithm fits a smooth surface to the original data, but can produce significant over- and under-shoots in areas of large gradients or when the data is noisy. In such cases WinDisp has two other gridding algorithms available. 



The first is a very simple nearest neighbour option. When this method is used, the value for a cell is determined by locating that data value which is closest to the centre of the cell and within the specified search radius and then assigning this data value to the cell. 



The second option available is the slightly more sophisticated Inverse Distance Weighting method. When this option is selected, the value for each cell is calculated by locating all data points within the search radius from the centre of the cell, and calculating a weighted average of the data values. By default the weighting function is usually inverse distance squared which is signified by the distance exponent being 2, but any positive value may be used. The distance slope value indicates the weighting given to points very close to the centre of the image cell. The distance weighting formula is defined as w=1/(s+r^a) where s is the distance slope value and a is the distance exponent. 



Once all gridding options have been set, the gridding process is initiated by clicking in the Grid Data button. If the Nearest Neighbour or Distance Weighting options are being used, gridding can be interrupted at any time by pressing the escape (Esc) key. 



Once the histogram and gridding options are no longer required click on the Done button to return to the calling form.



Menu Items



This menu has the following menu items



Options - which are the same options described above



Copy to Area Limits - clicking on this menu item copies the current data file easting and northing limits to be copied to the map layout limits. This allows the user to easily define the map layout to include all data read from the file by using the limits of the data area as read from the file, or to limit the layout area to a subset of the data limits by changing the area limits before clicking on the Copy to Area Limits menu item.



Copy from Area Limits - clicking on this menu item copies the current map layout easting and northing limits to be copied to the easting and northing limits on the form. This allows the user to generate grid files with a standard size defined by the layout limits, or to only grid the visible region if the Clip Data to Area Limits menu item is currently turned off.



Define Colour Legend - when this menu item is clicked, the current data variable’s histogram is used to define eight equal area intervals which are copied to the colour legend. This option can be used to display posted data values colour coded according to the data ranges specified in the colour legend.



�9 Generating UBC IP Inversion Files



Once an IP pseudosection layout has be defined which contains resistivity (or potential) and chargeability panels, the IP data can be written out in the format required for UBC inversion. In addition to the UBC data files optional mesh and topography files can be generated and batch files to run the inversion will also be produced. The inversion can be run using these batch files or WinDisp can be used to start, interupt and assess the inversion process.



9.1 IP Options Menu



The basic parameters controlling the UBC inversion can be accessed by clicking on the Edit > Posting > IP Options menu item. This brings up the form illustrated below.



This menu allows the user to set specific parameters for the inversion for the current layout. The user can also make changes using this menu and make the new values the defaults for all future layouts by using the File > Store Defaults menu item.



For individual layouts, the user can also enter file names for the initial and reference models, dip file and weight file for both potential and chargeability inversions. However all these files need to be created externally to WinDisp.



The use of each of the parameters in the UBC inversion is beyond the scope of this document and the reader is referred to the relevant UBC DCIP2D documentation.
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�9.2 Set UBC Output Options



In order to generate the required UBC inversion files WinDisp needs to have additional information on the data contained in the IP data file and needs to know how to assign an error value to each data point in the survey. This information is entered using the Set UBC Output Options button on the Post Variable Definitions Menu. Clicking on this button brings up the form illustrated below.



The information on this form is automatically generated by the IP Pseudosection layout generation process, but can be modified by the user before the UBC inversion files are created.



The first piece of information needed is the type of data represented by the selected data variable. The UBC DCINV2D inversion process uses potential, so if the data field contains resistivity then WinDisp needs to be told that so the resistivity value can be converted to potential. This is done using the Channel Contains drop-down list to select resistivity (or potential). 



The chargeability field required for the UBC IPINV2D inversion process  (preferably Mx) also needs to be identified. Again this is done by selecting the data variable containing the chargeability value to be used and then using the Channel Contains drop-down list to select chargeability. 



All other data variables in the pseudosection layout will be ignored in the UBC file creation process and should have the Channel Contains field set to Other.

	

The Divide data value by field  allows the user to scale the data value read from the file by the specified value before writing to the output UBC file. This allows eg pfe values to be roughly converted to chargeability by specifying a value of 6.5.
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The Data Uncertainty Option permits the user to select one of two methods for defining the data uncertainty used in the inversion process. The upper option allows the user to select a particular data column to use as data uncertainty (this option is automatically set for Zonge avg files in the import process). The Error is Percentage check box allows the error value to be correctly interpreted if it has been expressed as a percentage of the actual data value in the data file.



The second data uncertainty option allows the user to define the error to be a specified percentage of the data value subject to the specified minimum value. This is suitable for IP data files which do not have columns containing suitable data uncertainty values.



Note that when data uncertainty values are computed the following extra checks are used:



If the data value is negative the data uncertainty value is increased to ensure the data uncertainty range extends above zero.



If the data uncertainty is read from the data file and happens to be zero, the uncertainty is calculated using the percentage value instead.



If the data uncertainty is zero it is increased to a nominal value of 0.001 for the potential and 0.01 for the chargeability.



9.3 UBC Menu Options



The final options governing the creation of the UBC inversion files are accessed via the UBC Output > Options menu item on the Data Posting Specifications Menu. Clicking on this menu item allows the user access to the following options:



Generate New Sub-directory - this option allows the UBC inversion files to be stored into a separate sub-directory under the current working directory, or simply created in the current directory. Leaving this menu turned on (the default state) tells WinDisp that the data should be written into a sub-directory. When WinDisp comes to the stage of writing the files the user is prompted to enter the name of a new or already existing sub-directory. The default name WinDisp assigns to this directory is the first 5 characters of the current line number (or data file name if no line number is used) with a “u” appended (to denote UBC). This name has no particular significance to WinDisp and the user is free to change the name. However bear in mind that the first five characters of the file name will be used as the base name for all the data, batch, input and grid files that WinDisp and the UBC IP inversion will create, so it is recommended that the name should uniquely identify the current line within the first five characters.



Generate mesh file - this option allows the user to either automatically generate a mesh file for use in the inversion (the default) or not. If the option is turned off, the mesh file in the UBC input files will be set to NULL indicating that the UBC code should generate it’s own mesh. If this option is turned on WinDisp will generate a mesh which uses a cell size of half the dipole spacing in the interval spanned by the extreme limits of sources and receivers. For the depth mesh it uses ¼ dipole cells down to 3 dipoles depth followed by a further 4 dipoles depth with ½ dipole cells. Outside these x and z limits the cell sizes are progressively increased to a distance sufficient to avoid boundary effects in the finite difference scheme used in the UBC code.



Generate batch file - this option directs WinDisp to create the batch files for running the UBC IP inversion code. If the files already exist of the user wishes to run the programs manually, this option can be used to disable their creation by WinDisp.



Output only at dipole multiples - generally IP data files contain only data at multiples of the dipole spacing. However some files also contain extra infill data which does not line up with the dipole spacing. Both WinDisp and the UBC IP inversion code can handle this situation, but by default WinDisp only outputs data aligned with the dipole spacing into the UBC inversion files. If the user wishes to include the infill data in the inversion, this option must be turned off before the data files are created. Note that WinDisp always assumes that all data is collected with a constant dipole length and writes the data to the UBC file using a constant source and receiver dipole length. If a data file contains data collected with more than one dipole length it is the user’s responsibility to remove all data except for the single dipole length of interest.

  

If the Output at dipole multiples option is turned off, WinDisp will read all data from the IP data file and output data for all sources starting from the left-hand side of the line. The mesh file generated will attempt to use the half dipole mesh as in the standard case, but will use half the spacing between successive source/receiver locations when this is less than the standard dipole spacing. (This is quite a complex operation, so if you encounter any problems with infill data please send a sample of the data to me so I can accommodate as much variation as possible).



9.4 Incorporating Topography Data



The UBC IP inversion code has the ability to incorporate topography effects when topography data is available. The first step in using topography is to include a panel in the pseudosection and associate the topography data with this panel. This is achieved by clicking on the File > Edit > Posting Specifications menu item to bring up the posting specifications menu. Next scroll through the data variable grid box to find and empty row, click in the row under the Data Variable Name column and select Topo File/Model Image in the drop-down list. Once this has been done click on the Define Data Variable button to bring up the Post Variable Definitions Menu. If this is the first Topo/Model panel being defined you will be prompted to enter the minimum and maximum topography limits with the defaults being the current IP depth limits. 



For the Topo File/Model Image data variable option, the Post Variable Definitions menu has the following form:
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Most items are the same as for ordinary IP variables, but the top part of the form has information specific to topography files and model display.



The first item is the Topo File name text box. If the user has a data file containing the topography information for the current line of IP data then the name of the file can be typed directly into this box. Alternatively double clicking on the text box or clicking on the small button to the right of the text box brings up the file selection dialogue box. If there is no topography file available, this field can be left empty. Note that the elevation locations in the topography file do not have to be aligned with either the dipole spacing or the generated mesh as WinDisp will interpolate to the actual locations required.



If there is a topography file entered, WinDisp sets the default format for reading this file to be line, east, elevation. If the data file does not conform to this structure, click on the Set Topo File Format button to bring up a form on which the format can be modified. This form is as follows:
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The top part of this form display the file name and the contents of the selected data file and the bottom part displays the parameters defining how data is to be read from the file. 



The first item to define is the First Line With Data value. This value specifies the line number on which the first data values occur in the file. This value must be an integer 1 or larger.



The next item to define is the Line Number Column value. This value specifies the column in the data file which contains the line number. If there is no line number, set this value to zero. If there is a line number set this value to the corresponding column and when the topo file is read, only data for which the line number conforms to the line numbers selected on the Data Coordinate Specification for will be utilised.



The Along Line Coordinate value specifies the number of the column which contains the along line coordinate used for displaying the IP and topo data. This value must be 1 or larger.



The Elevation Column value specifies the number of the column which contains the elevation data. This value must be 1 or larger.



The Base Level value specifies the value which is to be subtracted from the data value in the file.



The Scale value specifies the value used to scale the data value in the file. The formula used is t=(z-base)*scale, where z is the value read from the file. These values are mainly of use when a topography 

Is being used to display a data quantity whose vertical scale is unrelated to depth eg geochemistry or magnetics. The base and scale values allow the user to modify the vertical scale within the panel so that variations in the data can be seen. Note that this change in vertical scale is not applied to grid, contour or DXF files.



In the right-hand lower corner of the form there is a data statistics display. Once the file format has been specified, clicking on the Calculate Statistics button causes WinDisp to read the data file and display the data statistics for the file. This gives a quick method to determine what the data range is for the data file, but note that only data within the easting limits for the current layout are included in the calculation.



Once the format has been correctly defined, click on the Done button to return to the Topo Definition form. Clicking on Cancel undoes any changes to the values displayed on this form and returns the user to the Topo Definition form



Returning to the Topo Definition form, the next two boxes allow the user to specify the minimum and maximum northing limits to display within the corresponding panel in the IP layout. These limits do not have to correspond to the northing (or depth) coordinate area limits which apply to the standard pseudosection panels but will display using the same map scale as modified by the topo scale defined in the topo file format. The panel will be enlarged (or reduced) to accommodate the specified data range. When a topo file name has been specified the minimum and maximum elevation limits should be set to display as much of the inverted data section as is of interest.



If the user does not know what the elevation limits are, clicking on the Set Limits From Topo File button will cause WinDisp to read the topo file and set the minimum and maximum elevations to the minimum and maximum values read from the specified file.



The Data Legend item can be used to specify the text displayed above the panel in which the Topo File/Model Image is displayed so that the user can identify what it is that is being displayed in that panel.



The Label Interval item can be used to specify how often coordinate labels are written in the along line coordinate direction. This is specified in the user data distance units.



The Axis Label item can be used to specify the text displayed to the left-hand side of the panel in which the Topo File/Model Image is displayed so that the user can identify the vertical units of the data displayed in the panel.



The remainder of the form functions as already described above for the standard IP data variables. The main difference for this panel is that the area limits in the y direction in the displayed plot are taken from the minimum and maximum elevation fields on this form rather than the limits displayed on the Area Limits form. Thus only those parts of the image and/or contour file between these elevation limits will be displayed.



Once the Topo File/ Model Image specifications have been defined, the IP pseudosection will now display as:
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�9.4 Output UBC IP Data



Once all IP and (optional) topography data has been defined and displayed satisfactorily and all UBC options set, the user can now click on the UBC Output > Output UBC IP Data menu item to initiate UBC data output. When this menu item is clicked, the user will be prompted to enter the name of the sub-directory to store the UBC data (if that option is turned on). Then the data file will be scanned to determine the number of source locations for the resistivity/potential data and the potential data UBC data file will be created. This process is then repeated for the chargeability data. Next the (optional) mesh and batch files are created, and finally standard inverted and error IP layout files are created.



The files produced by WinDisp are as follows (where <base> is the first five characters of the specified directory or IP data file): 



<base>.bat	master batch file to run full inversion

<base>pt.bat	batch file to run the potential stage of the  inversion

<base>ip.bat	batch file to run the chargeability stage of the  inversion



<base>.sh	master unix shell script to run full inversion

<base>pt.sh	unix shell script to run the potential stage of the  inversion

<base>ip.sh	unix shell script to run the chargeability stage of the  inversion



<base>.msh	mesh file used for both potential and chargeability inversion

<base>.top	topography elevation data interpolated to the locations in the mesh file



<base>pt.inp	input parameter file for the potential stage of the  inversion

<base>ip.inp	input parameter file for the chargeability stage of the  inversion



<base>pt.obs	input data file for the potential stage of the  inversion

<base>ip.obs	input data file for the chargeability stage of the  inversion



<base>.mde	input model file for the Zonge inversion program

<base>.avg	input data file for the Zonge inversion program



inv<base>.csf	inverted section layout containing the original resistivity and ip pseudosections and also inverted model sections

err<base>.csf	inverted section layout containing observed data, modelled data, observed-modelled and Z score pseudosections  for resistivity and ip 



Note that in the two obs data files the actual plot point, n level and original data values are included to assist in identifying bad data values if the inversion process does not converge properly.



�9.6 Running the UBC Inversion



Once all UBC output file have been created, the inversion can be run from within WinDisp or from the MS-DOS command prompt. To run the inversion from WinDisp click on the menu item Edit > UBC IP Options and click on the Control Inversions tab to bring up the following form:
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This form is the main location for interacting with the inversion process and the functions available will be described below, but for now, to start the inversion simply click on the Start Full Inversion button.



To start the inversion from the command prompt, start the MS-DOS Prompt box, change to the directory containing the UBC data files and running the master batch file (ie type it’s name at the DOS prompt).



For either method for starting the inversion the user needs to ensure that the directory in which the UBC executeables are located is in the path for the DOS prompt. The easiest method for ensuring this is to add the \WinDisp directory to the path definition in the autoexec.bat file in the root directory. This can be achieved by adding a line of the form



	set PATH=C:\WinDisp;”%PATH%”



to the file. Alternatively, at the DOS prompt type in the command path to see which directories are currently in the path and copy the UBC inversion and utility exe’s to one of the directories listed. The UBC exe’s are:



	dcinv2d.exe	this performs the potential inversion and generates a conductivity model

	ipinv2d.exe 	this performs the chargeability inversion and generates a chargeability model

	iptogrd.exe	this utility converts the UBC model file to a Geosoft binary grid

	ubctodat.exe 	this utility converts the UBC data files to Geosoft binary grid files

	zngtogrd.exe	this utility converts the Zonge model file to a Geosoft binary grid

	zngtodat.exe 	this utility converts the Zonge data files to Geosoft binary grid files

	slicer.exe	this utility can be used to generate depth slices from multiple grid files



After the UBC inversion has completed the following files will have been created:



<base>pt.con	the final conductivity model generated in the potential stage of the  inversion

<base>pt.pre	the forward model of the potential data generated from the final conductivity model

<base>pt.log	detailed information on the progress and success of the potential inversion

<base>pt.out	summary information on the progress of the potential inversion



<base>ip.chg	the final chargeability model generated in the chargeability stage of the  inversion

<base>ip.pre	the forward model of the chargeability data generated from the chargeability model

<base>ip.log	detailed information on the progress and success of the chargeability inversion

<base>ip.out	summary information on the progress of the chargeability  inversion



<base>.out	data file converting obs and pre files to standard column format, includes columns for observed, modelled, observed-modelled and Z scores for resistivity and chargeability 



<base>pt.xyz	xyz data file for the conductivity model (masked to the topography)

<base>pt.grd	unsmoothed Geosoft grid file of the conductivity model (masked to the topography)

<base>rs.grd	unsmoothed Geosoft grid file of the resistivity model (masked to the topography)

s<base>pt.grd	smoothed Geosoft grid file of the conductivity model (masked to the topography)

s<base>rs.grd	smoothed Geosoft grid file of the resistivity model (masked to the topography)



<base>ors.grd	smoothed Geosoft grid file of the observed resistivity data

<base>mrs.grd	smoothed Geosoft grid file of the modelled resistivity data

<base>ers.grd	smoothed Geosoft grid file of the observed- modelled resistivity data

<base>zrs.grd	smoothed Geosoft grid file of the Z score for the resistivity data fit



<base>ip.xyz	xyz data file for the chargeability model (masked to the topography)

<base>ip.grd	unsmoothed Geosoft grid file of the chargeability model (masked to the topography)

s<base>ip.grd	smoothed Geosoft grid file of the chargeability model (masked to the topography)



<base>oip.grd	smoothed Geosoft grid file of the observed chargeability data

<base>mip.grd	smoothed Geosoft grid file of the modelled chargeability data

<base>eip.grd	smoothed Geosoft grid file of the observed- modelled chargeability data

<base>zip.grd	smoothed Geosoft grid file of the Z score for the chargeability data fit



In addition the above files there may be files with the extension .sem or .stp. These files are used by WinDisp to flag that the inversion should be terminated and can be safely deleted. The files regional.grd and masl1.dat can also be deleted. If the inversion crashes or is manually interrupted there may also be a variety of temporary files (starting with zz) which can be deleted (provided the inversion is not running).



�9.6 Displaying the Inversion Results



Once the inversion has been completed the results of the inversion can be viewed using the standard inversion and error csf files generated by WinDisp. 



The inversion csf produces a layout as illustrated below:
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This layout contains the resistivity pseudosection and inverted model on the left-hand side and the chargeability pseudosection and inverted model on the right-hand side. By default the inverted section layout loads the block images generated directly from the UBC model so that the user can clearly identify the resolution of the mesh used for the model. If the user prefers to see smoother versions of the inverted models, the Define Data Variable menu on the Posting Specifications Menu can be used to change the displayed grid files to the smooth versions instead. For the above model the display then becomes:
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The other standard layout generated by WinDisp when generating the UBC output files is the error layout. For the above inversion this generates a layout with the following form:
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This layout has resistivity on the left-hand side and chargeability on the right-hand side, with resistivity being displayed using colour histogram equalisation and chargeability without histogram equalisation. The top-most panel contains the observed data, the second panel contains the forward model generated by the UBC inversion (displayed using the same colour range as the observed data). The third panel contains the percentage difference between the observed and modelled data and the fourth panel contains the Z score for the modelled data both displayed with colour histogram equalisation turned off.



All of these layouts can be manipulated using the methods described above for standard IP layouts and panels can be removed or added to reflect user preferences.





�10 Running, Monitoring and Modifying UBC IP Inversions



Once WinDisp has been used to generate the UBC inversion data files, the inversion process can be initiated, monitored, interrupted, modified and resumed using the Edit > Post > IP options menu item.



10.1 Starting the UBC Inversion



The inversion process generally takes a significant amount of time, so the best way to run more than a single inversion is to set up a batch file which calls each of the individual batch file for each line. This batch file would have the structure:



cd 10000n

call 10000n.bat

cd ..\11000n

call 11000n.bat

…



However, if desired, WinDisp can also be used to start the currently defined inversion. To do this click on the Edit > Post > IP options to bring up the UBC IP Inversion Parameters for (displayed above in section 9.1) and click on the Control Inversion tab:
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If the Start Inversion button is clicked, WinDisp will check that the inversion files have been created and launch the batch file to run the UBC inversion. Care should be taken that the inversion is not already running as there are no checks in the inversion code to ensure that multiple processes are not running.



Alternatively, the individual potential and chargeability stages of the inversion can be run independently by first clicking on the Start Resistivity Inversion button and, when the resistivity stage is complete, then clicking on the Start Chargeability Inversion button.



10.2 Monitoring the progress of the UBC Inversion



Once the inversion is running (either through using the MSDOS box to launch the batch file or through WinDisp), the progress of the inversion can be monitored by clicking on the View Progress button. When this is done the current status of the inversion, the latest misfit, model norm and Lagrange multiplier and graphs of the data misfit and model norm as functions of the iteration number are all displayed. This takes the form:
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The data misfit is plotted using crosses and is plotted using a logarithmic scale on the left-hand side. The model norm is plotted using diamonds and is plotted using a linear scale on the right-hand side. In the above example the status indicates that the data misfit in the inversion for the conductivity has plateaued and dcinv2d cannot reduce it. The horizontal line indicates the current target misfit, so it is clear in the above case that the inversion has failed.



Clicking on the Display Information For drop-down list allows the display to be switched to monitor the chargeability inversion (once it has commenced).



�10.3 Interrupting the UBC Inversion



If the inversion is running (either through using the MSDOS box to launch the batch file or through WinDisp), and the progress of the inversion as monitored using the View Progress button indicates that the inversion will not succeed, the current inversion process can be interrupted by clicking on one of the Stop Inversion buttons. WinDisp does not have any means for directly terminating the inversion, so to signal that the inversion should be terminated, WinDisp creates three files : dcinv2d.stp, ipinv2d.stp and invert.stp and delete two file : dcinv2d.sem and ipinv2d.sem.  The deletion of the .sem files is used as a signal to instruct the ubc exe’s to terminate. Dcinv2d and ipinv2d create these .sem files and regularly test for the presence of these files and terminate if  they have been deleted.  If present, the .stp files stop dcinv2d and ipinv2d from running and also stop the batch files from running the iptogrd and ubctodat utilities. 



Note that as a result of the indirect nature of the termination of the inversion process it may take some time between clicking on the termination button and the inversion actually terminating. To deal with this WinDisp sets a timer and repeats the termination process at 5s intervals for one minute. If the user attempts to start the inversion again before this time has elapsed, WinDisp will warn the user and ask the user if they want to allow the termination process to continue.



The best method for determining if the inversion has been terminated is to check that the MS-DOS box for the inversion has the caption “Finished”. Alternatively both the resistivity and chargeability progress can be viewed and both should display the message “Inversion terminated by user”.



10.4 Modifying the UBC Inversion Process



If after running the inversion the results for either the resistivity or chargeability inversion indicates that not enough iterations have been performed to achieve convergence WinDisp can be used to initiate extra iterations. To do this click on the Edit > Post > IP options menu item and click on the Inversion Parameters tab to bring up the form displayed in section 9.1. From this form change the number of iterations to the desired number of extra iterations to be performed for the resistivity and/or chargeability stages. Once this has been done click on the Control Inversion tab to bring up the form displayed in 10.1. 



Once this form is displayed, clicking on the Set Resistivity Inversion to Continue and/or Set Chargeability Inversion to Continue buttons causes WinDisp to rename the existing *.inp files to *.bak and create new *.inp files with the continue flag set to 1. Note that when the new *.inp files are written, all the current inversion parameters are written, so it is possible to change the chi factor, initial and reference models as well.



After the new *.inp files have been created the entire inversion can be restarted using the Start Full Inversion button, or the individual stages can be initiated using the Start Resistivity Inversion and Start Chargeability Inversion buttons.



Note that the chargeability inversion uses the conductivity model generated in the Resistivity inversion stage, so if extra iterations are performed for the resistivity, extra iterations should also be performed for the chargeability inversion so that the latest conductivity is included in the chargeability inversion.



Note also that if the Start Resistivity Inversion button is used to perform extra iterations then this process should be either allowed to run to completion or terminated before the Start Chargeability Inversion button is used as ipinv2d uses the latest conductivity model to compute a sensitivity matrix so the user needs to ensure that dcinv2d is not updating the conductivity model.



In extreme circumstances (such as major changes to the initial or reference models) the Set Resistivity Inversion to Restart and/or Set Chargeability Inversion to Restart buttons cause WinDisp to rename the existing *.inp files to *.bak and create new *.inp files with the continue flag set to 0.  The Start Full Inversion button on the Control Inversion tab, or the individual stages can be initiated using the Start Resistivity Inversion and Start Chargeability Inversion buttons to start the inversions from the beginning.



10.5 Assessing the UBC Inversion Process



If the data misfit plateau’s off as a function of the iteration index and the target misfit cannot be achieved, the dcinv2d and ipinv2d programs will terminate and the status line on the Progress of Inversion tab will display the message “Inversion failed : misfit could not be achieved”. If the misfit is close to the target, the chi factor could be increased and extra iterations performed. However, before this done, the results of the inversion should be assessed to ensure that the failure to converge is not the result of bad data values.



Clicking on the Assess Results tab brings up the following form:





�



This form displays a simple pseudosection style grid showing the Z scores for the inverted data. The Z score is calculated using the formula:



	Z = ( observed data - modelled data ) / data uncertainty



and thus represents the goodness of fit between the observed and modelled data. To help in assessing where the modelled data is a poor fit to the observed data the Z scores are colour coded as follows:



Z			text colour



0 <= |Z| < 2  		black

2 <= |Z| < 4  		magenta

4 <= |Z|   		red



The first time that this screen is displayed, the user should click on the Data Value option item to switch the displayed values over to the observed data values. When this option is selected, the data statistics immediately beneath the pseudosection grid displays some simple statistics relating to the observed data. The user should confirm that the reference models are consistent with the average values for the data being inverted.



If the reference models are appropriate for the data being inverted, the user can switch back to the Z score display by choosing that option and then use the scroll bars to scan across the pseudosection to locate where the inversion is having difficulty fitting the observed data. Once a high Z score is located, the user can switch between the observed, modelled, uncertainty, Z score and percentage displays to determine the cause of the poor fit. To assist in identifying the locations of the poor misfit, all data values displayed are colour coded according to the Z score at that location.



The cause of the poor misfit can be difficult to identify as a large Z scores at any location can result from neighbouring bad data values in the section and not necessarily be an indication that the data value with the bad Z score is itself bad.



If the Z score is isolated and the data value at that point is significantly larger (smaller) than the surrounding data and the modelled value is significantly smaller (larger) than the observed data value, this indicates that the smoothness constraints in the inversion parameters is preventing the inverted model fitting that particular data point to the degree requested by the associated data uncertainty. 



The more general situation is where there is a cluster of large Z scores. In this situation that region of the pseudosection needs to be examined in detail to determine why the inversion is having difficulty fitting the data. The cause may be a number of bad data values in close proximity causing the inversion goals of good data fit and smoothness of model to conflict. This is especially the case where there are negative observed data values. In this case the data uncertainty values generated using the simple % of data value rule are almost certainly much smaller than they should be. WinDisp does make the uncertainty at least equal to the absolute value of the data value itself thus allowing the UBC inversion to model the observed data value with zero without incurring any substantial penalty. However if most or all of the surrounding observed data values are larger than zero, the smoothness constraint in the UBC inversion will generally produce large Z scores for all data in proximity to the negative value. To overcome this effect, the data uncertainty for the negative data value needs to be increased to a value which allows the inversion to generate a modelled value which approaches the average of the surrounding non-negative values. For example if the negative value is -6 with a data uncertainty of 6.1 and the average of the surrounding data values is 20, the data uncertainty should be increased to at least 12 so that the smoothness and data fit goals can be brought into balance (unless there is some overriding information that smoothness constraints should not be allowed to determine the modelled value).



In all of the above cases there are two main strategies for modifying the inversion process to achieve the desired goals:



Modify the alpha parameters to permit less smooth models and restart as described in the previous section



Increase the uncertainty value associated with the data values in question to reduce the Z scores for those location and carry out extra iterations



The first strategy can be achieved by using the Inversion Parameters tab to modify the alpha values and then restarting the inversion. The second strategy can be achieved by either directly editing the *.obs input data file to change the relevant data uncertainty values or by using the Asses Results tab to modify the relevant data uncertainty values.



Modifying the data uncertainty values using the Asses Results tab can be achieved in one of two ways. All uncertainty values can be increased or decreased by a specified percentage by entering the desired percentage change in the Increase all by % text box (a positive value for increase, a negative value for decrease), and clicking on Increase all by % button.



Individual data uncertainty values may be changed by clicking once on the desired location in the pseudosection display of the Assess Results screen. The observed, modelled, uncertainty and Z score values for this location are then displayed immediately beneath the pseudosection display, and the data uncertainty value for that location is displayed in the Data Uncertainty edit box at the left-hand lower side of the form. This data value can then be changed as required. The changed value can then either be cancelled by clicking on the Cancel Edit button, or stored in the displayed pseudosection by clicking on the Store Edit button.  Note that at this stage it is only the data value stored in memory which has been changed and the *.obs files still have the original data values. To store edited values in the *.obs files the user needs to click on the Save Changes button. Doing so causes WinDisp to rewrite the *.obs files using the new data uncertainty values. Clicking on either the Cancel Changes or the Reload Data button causes all changes to be lost.



Once either (or both) approach has been applied, extra inversions can then be performed and the results reassessed. Indeed the progress of the Z scores in the area of interest can be monitored as the iterations proceed by clicking on the Reload Data button after  each iteration is completed so the effect of the changed data uncertainty cab be assessed.



10.6 Controlling the UBC Inversion Process



As mentioned above the individual resistivity and chargeability stages of the inversion process can be controlled using the buttons on the Control Inversion tab. This tab allows the *.inp files to be changed so that extra iterations will be performed for the individual stages, or the individual inversion stages restarted from scratch. This tab also provides buttons for starting the individual stages independently and also for stopping each of the stages. All these functions behave in a similar fashion to the overall Start Inversion, Stop Inversion buttons on the Progress of Inversion tab and so will not be detailed further.
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