Mag and Gravity Inversion process
Gravity inversion

1. Start WinDisp 
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2. Double-click on the Display an Image option and select the grav.ElJoul09_bouguser.grd grid file

[image: image2.png]x

()~ (1 - Conputr - DATAPARTL ) - WUGHE = o dte = Gty = S

[scoreh 2
| Organize ~ 155 Views =[] NewFolder @
Folders v MNome & || Dste modiied_|+| Type [lsze <]
B 2] EboulBovguer UBC 24/09/2010 1028 A File Folder
1 Decornugation i mgGrav_Boug 8/08/20111033 AM  File Folder
Lo - || boug(tot) Elloultg.ers 30/06/2009 225 AM  ER Mapper Raster ... 1K8
0l GravityTc 23/08/2009130 PM R Mapper Raster .. 268
)l Instalisets 26/07/20101201 P... GRDFile %k8
L P data 26/07/201012:02 ... GRD File: 26K8.
i Peanut 26/07/20101202P..._GRO File 2516
Ui screenshots
& 20/07/20001031 A... 2K8
1 Driling tutoialzip
[ P datazip
11 WiipWarshop 1 Nots e 2. B
s WinDisp Workshop Notes Feb 21.zip
s wuG2010
i Eoul
). Eloul dataset
U Gravity
1L Maanetics
Fie name: [grav ElJoi09_bouguergrd =] [image Fies <





3. Select Colour Sun Illumination as the Image Style
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4. Click on the Display grid details button and then click on the Calc Stats button and note the average grid value
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5. Click on Done, then Done again and specify 10000 as the required plot scale when prompted
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6. Click on the Edit> Image menu item. Select the EIJoul_srtm_topo_uc100.grd DTM grid file and display it 
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7.
As the data appears to be ok, click on the Utilities> Create a mag/grav inversion menu item to display the 3D Inversion Setup Utility
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8. Select 5: SciComApp MGinv3D as the inversion method and set the data type to 0: Gravity
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9. Click on the Observed data tab and set the Sensor location to Height above topo and set the offset to 0.5 to indicate that be it is 0.5m above the topo. Next change the Observed Data File Type to Grid Data and select the Bouguer grid and then click on the Set Limits from Data button
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10. Click on the Topo Data tab and select the DTM grid to define the topo for the inversion
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11. Click on the Mesh tab and change the cell sizes to 50m and change the minimum Z value to -2000
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12. Set the Region to View to Total Region, select the Bouguer grid as the Image to view and click on the View Mesh layout button
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Note: the up/down buttons below the image can be used to modify the inversion limits to ensure that the required anomaly is being covered by the inversion mesh.

13. Click on the Create Inversion tab, specify an output location and the name of a folder in which to create the inversion files. You should also add a description of the inversion to remind yourself of the important aspects.
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Note: When you create the inversion the specified folder will be created if it does not already exist. The files that will be created are:
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Any existing files with the same name will be overwritten, but an existing mtx file will not be deleted. This is useful if you just want to modify the inversion parameters as you can then use the run_mginv3d batch file to use the existing mtx file to run the new inversion.
The file creation process will also save an input parameter file with the same name as the specified directory name. However it is also a good idea to save the parameters manually using the File> Save Parameter File menu item

14. Click on the Start Inversion button and the inversion process will be initiated by starting a minimised Command window which calls the regional.bat batch file.
15. Once the inversion has finished running, check the mginv3d.aux file to ensure that the desired misfit has been achieved. The log file for this inversion is:
MGinv3D Inversion progress looks like this:

MGinv3D Inversion progress

   Iterations   data_misfit    model_norm    total_norm       Time

           0         77.06          0.00       5938.44

           1         67.74          0.00       4588.53       5.1

           2         41.61          0.11       1731.29       3.4

           3         20.66          0.21        426.97       2.9

           4         15.42          0.28        237.85       3.1

           5         12.41          0.34        153.99       3.0

           6         10.83          0.39        117.31       4.2

           7          8.42          0.50         70.96       4.6

           8          7.61          0.56         57.95       3.6

           9          6.52          0.65         42.53       3.4

          10          5.62          0.74         31.58       4.8

          11          4.89          0.84         23.88       2.5   0*

          12          0.32          1.77          0.11     131.8   9+

          13          0.32          1.77          0.10       3.0   0*

          14          0.32          1.77          0.10       3.1

          15          0.31          1.78          0.10       3.0

          . . . .  

          22          0.22          1.80          0.05       2.5

          23          0.21          1.80          0.04       5.5

          24          0.19          1.81          0.04       3.5   0*

          25          0.03          1.60          0.00     131.0   9+

          26          0.03          1.60          0.00       5.1   0*

          27          0.03          1.60          0.00       3.9

          28          0.03          1.60          0.00       3.3

          29          0.03          1.60          0.00       3.2

          30          0.03          1.60          0.00       3.1

          31          0.03          1.60          0.00       2.2

          32          0.03          1.60          0.00       4.7

          33          0.03          1.60          0.00       3.5

          34          0.03          1.60          0.00       2.9

          35          0.03          1.60          0.00       2.5

          36          0.03          1.60          0.00       2.5

          37          0.03          1.60          0.00       2.4
You can see that the inversion has fitted the data to better than requested ( the target misfit value is 1).

You should also examine the error.dat file and the grid generated by the UBCerror utility program (observed.grd, modeled.ged, percent_error.grd and zscore_error.grd) as these will show how well each data point has been fitted and you can check for structure in the error that indicates that there may be a problem with the inversion. The error.dat file for this inversion looks like this:

x,y,elev,actual,modelled,difference,zscore

  566375.0 2177225.0     128.6        1.51        1.51      0.0020      0.2030

  566425.0 2177225.0     128.7        1.47        1.47      0.0000      0.0020

  566475.0 2177225.0     128.7        1.44        1.44      0.0006      0.0550

  566525.0 2177225.0     128.8        1.40        1.40      0.0002      0.0160

  566575.0 2177225.0     128.8        1.38        1.38      0.0002      0.0190

  566625.0 2177225.0     128.9        1.35        1.35      0.0004      0.0410

  566675.0 2177225.0     129.0        1.33        1.33      0.0004      0.0370

  566725.0 2177225.0     129.0        1.31        1.31      0.0001      0.0090

  566775.0 2177225.0     129.1        1.30        1.30      0.0000      0.0000

  566825.0 2177225.0     129.2        1.29        1.29     -0.0001     -0.0080

  566875.0 2177225.0     129.3        1.28        1.28      0.0002      0.0170

  566925.0 2177225.0     129.4        1.27        1.27      0.0003      0.0340

  566975.0 2177225.0     129.5        1.25        1.25      0.0003      0.0260
. . . . .

16. A good way to examine the fit is to load the multipanel display named inversion_model_errors.csf that is created by the UBCerror utility called by the inversion batch file. The shows the sun illuminated observed and modelled grids using the same histogram. The other two grids are the percent error and Z-score both displayed using a uniform colour stretch of -5 to 5 for the percent error and -2 to 2 for the Z-score.
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17. If the model is not acceptable and you want to try out different settings for the inversion parameters, go back to the inversion setup form (and load the parameter definition file if required and turn on the Generate MGinv3D Inversion Variation checkbox. All of the parameters which can be varied without requiring the mtx file to be regenerated are highlighted in green.
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18. Change the settings as required and then click on the Create Inversion tab, set the directory to point to the folder containing the current inversion (ie the one where the mtx file is located), specify the name for the subdirectory, fill in the description details and then click on the Generate Variation button and a new folder will be created with a minimal set of files to reuse the existing mtx and observed data files.
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19. To view the model, click on the 3D Models menu item to bring up the 3DModeller form and select the mesh and model file for the inversion
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20. Once you have loaded the mesh and model, click on the Display Options tab to view the range of model values
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21. Next click on the View Model tab, change the Section to View to Topo Draped Depth slice and change the Blue value to 0.
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22. You can view all depth slices using the scroll bar at the right-hand side of the image. You can also export the images for the selected section type by clicking on the Save Sections button. Using this facility allows you to export the data in XYZ, Geosoft grid and MapInfo format. You can also create a multipanel display of the slices, manually select which slices to export and display any currently defined drillhole data.
23. To view the model as a 3D isosurface, change the Isosurface value to 0.01 and click on the Start 3D Viewer button.
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Magnetic Inversion

1. Start WinDisp 
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2. Double-click on the Post Data From a Text File option and select the required data file
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3. Set the First Data Line to be 5 and the Line with data names to be 4 and click on the Check Format button
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Note: This file is in Geosoft line format, so you need to specify that the line “Line 76300” is the first data line even though it does not contain data. The Line keyword will be used later to specify the line number.

4. Click on Next and the data Names form will be displayed
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5. Click on Done again and the Posting Style selection form will be displayed. Select Profiles and then click on OK and the Posting Coordinates definition form will be displayed
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7. On the Posting Coordinates form select X as the X variable, Y as the Y variable and turn on the Implicit Geosoft Line Definition checkbox.
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8. Then click on the Define Line Exclusion List to display the Line List form and click on the button labeled Load Line List from Data File to populate the line list. If there are any lines that you want to exclude (eg tie lines), then simply click on the line numbers in the Include Lines list and it will be swapped to the Excluded Lines list.
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9. Click on Done to close the line list form and then on OK to close the Coordinates definition form and the Data Posting Specification from will be displayed. On this form set the max Station spacing to 20 (any consecutive readings which are further apart than this threshold will force a break in the line) and the Min Station Spacing to 1 (any consecutive values closer than this will be averaged into a single value). Then click on the first line in the variable list and select mag_cor from the available data fields.
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10. Click on the Display Data Range button and the data will be read from the file and displayed on the data Histogram and Gridding form
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11. Click on the Copy Limits> To Plot Limits, enter 5000 as the desired map scale. Then click on Done and click on the Define Data Variable button to display the posting Variable Specifications form.
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12. Set the baseline value to 35000 and the Scale to 50  (this sometimes needs a bit of experimentation to get the right balance between the line spacing and the data range). Then click on Done, OK and then Display!
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13. Clearly there is a lot of noise in the data measurements and we need to deal with it in some way. It is possible to grid the data as it stands and then smooth the resulting image. It is also possible to apply a despiking filter to the profile data before it is gridded. To do this, click on the Edit> posting> Edit posting Specifications menu item. Then click on the Filter Profile menu item and turn on the Despike option. Next, change the Filter half-width to 5. Click on OK and then Display!.
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14. With the data filtering defined to your satisfaction, click on the Display Data Range button, set the Easting cell size to 10, and change the default search radius to 125. Then specify the output grid file name and format, click on the Grid Data button and the data will be gridded.
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15. Click on Done, OK and then click on the Edit> Images menu item, select the grid file that was created and specify Colour Sun Illumination as the Image Style. Then click on Done and then Display!
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16. Note that the data is still quite noisy, so repeat the process with a filter half-width of 11.
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17. Click on the Edit> Area Limits, Scale and Projection menu item and click on the Projection tab and change the Projection to UTM, the zone to 28 and the spheroid to WGS84. The geographic limits for the display are now defined.
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18. Click on Done and the on the Edit> Image menu item and then the Transform button. Select Reduction to the Pole as the transform, turn on the FFT checkbox, select Remove trend plane option and set the Edge roll-off to 11. Then enter 1/6/2010 as the Date, 100 for the Elevation and click on the Calculate IGRF button. As the geographic limits are defined for the display, the lat/lon of the centre of the display is entered and the IGRF calculated. If the geographic limits are not defined, you can enter the values manually. Once you have calculated the IGRF values, click on the Copy button to copy the values into the RTP transform parameters fields (note, you can simply enter these values manually). Finally, turn on the Stabilize RTP check box, define the Output grid file name and (optionally) the grid file format and click on the Perform Transformation button and the specified transform will be applied and the grid file created.
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19. Click on Done to return to the Image Specifications form and select the grid file that was created and click on Done. Next, click on the Edit> Display list menu item and tuen off the Data Posting checkbox and click on the Select button and then click on Display!
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20. Click on the Edit> Images menu item, select the original grid file again and click on the Transform Grid button. The form will still display the RTP parameters, so simply click on the Transform drop-down list and select the VRMI option. This transform requires the field inclination and declination which have already defined for the RTP transform. If the values are not specified, they can be calculated as above or entered manually. Click on perform Transform and the on Done, select the VRMI grid file that was created, click on Done and the Display!
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21. For this inversion, no topographic information was collected, so the SRTM data will be used instead. The file for this area is N19W015.hgt and was downloaded. To display the images, start a new layout, select the file N19W015.hgt, set the image style to sun illumination and click on Display (you can turn the Frame display off if the warning message you get with the standard scale of 5 is annoying).
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24. The first thing to note is that the grid contains null data values. To fix this, click on the Edit> Images menu item, click on the Transform grid button and select the Fill Holes in Grid. Set the Filter half-width to zero, specify an output grid file name (a simple N19W015.grd is good). 
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25. Click on Done, then select the grid file just created, click on Display Grid Details and then click on the Calc Stats button and you will see that there are no nulls in the converted grid.
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26. Click on Done and then on the Transform Grid button and select the Convert Geographic Grid option. Then click on the Define Source and Target Coordinate projections button to display the multi-stage coordinate transform definition form
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27. Turn on the Define Source Projection check box and click on the Define Source projection button to display the Define Projection form. Set the values as in step 17 above.
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28. Click on Done, change the Target Coordinate type to planar, enter a sample location and click on the Test button
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29. Click on Done to return to the main Transform definition form and click on the Calculate Cell Size button to determine the approximate planar cell size equivalent of the geographic cell size. Then specify an output grid file name and format and perform the transform to generate the converted grid file.

30. Save the layout specifications for future reference, start a new layout and display the converted grid file
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31. To make the grid more manageable, reset the area limits to that of the mag grid, reselect the transformed srtm grid and export just that part which overlaps the mag survey using 25m cell sized
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32. The SRTM data at this scale is very noisy, so to make it more meaningful, apply an upward continuation of 100m
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33. Click on the Utilities> Create mag/grav inversion and select MagGrav V1 as the inversion method and Magnetic as the data type and fill in the magnetic field parameters
[image: image51.png]File Change Working Directory
Paramotors | ObsewvedDa | TopoDaa = [ Ceseimeson )
Inversion Parameters.

Inversion Method |5 SciComApp MGmV3D =]

Inversion Mode [ Normal 30 -





34. Click on the Observed Data tab, set the data type to Grid Data, select the despiked grid file, set the sensor to be 1m above topo and the target misfit to 0% + 1nT. Finally, click on the Set Limits for Data button to fill in the Base value as the average TMI.
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33. Click on the Topo Data tab and select the DTM grid
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35. Click on the Mesh tab and click on the File> Read Paramater File> Mesh Deinitions menu item and select the gravity inversion setup file to set the X, Y and Z mesh definitions as follows:
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36. Click on the Create inversion tab, specify an output folder and create the inversion files and then run the inversion as before.
37. Start the 3DModeller form and load the mag inversion mesh and model and click on the Display Options tab to check the data distribution
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38. Click on the 3D Files tab and specify the dtm as the Topography Image and the tmi grid as the Draped image
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39. Click on the View model tab and select Topo draped depth slice as the Section to View
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40. Click on the Edit> Mask Model using Topo> Clip model laterally using Draped Grid menu item to remove those parts of the model which are not covered by the survey. (Note that cell split and smooth model are turned on)
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41. Set the isosurface value to 100000 and click on the Start 3D Viewer button
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42. You can keep adding more isosurface levels by setting the value on the 3DModeller form and then using the Create New 3D Object. Another option is to click on Build List button on the Display Options tab. Then use the List> Create Linear List and specify no name, a minimum value of 50000, a maximum of 150000 and an increment of 10000 and click on Done
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43. Next click on the Build isosurfaces button and specify MGinv3D as the name of the parent node to create and click on Done to close the form
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44. Turn on the 0.02 g/cc density isosurface and the 100000x10^-6SI susceptibility isosurface note that there appears to be a anticorrelation between the mag and gravity isosurfaces
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45. Add the TMI image and observe how the model compares with the TMI data
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46. Add the VRMI grid and observe that there is a reasonable agreement with the inversion model
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47. Finally, here is a display of the TMI, RTP, VRMI images along with the forward calculation of the MGinv3D and UBC models using a vertical field.
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