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Inversion
All interesting problems in the world are inverse problems which take the basic form:

Given a set of observed data, what is the underlying model?

These problems are called inverse because they are the opposite of the forward problem:
Given a model, what are the observed data values?

Generally the forward problem is a lot easier to solve than the inverse one, so most methods for solving the inverse problem use multiple forward problems to find the required solution.

Some examples of inverse problems are catching a ball, intercepting a missile, driving a car, interpreting an x-ray, CAT, PET and MRI scans, most of geology and geophysics.

Interpretation of mag data is quite clearly an inverse problem. The observed data is the distribution of TMI data collected on the surface of the earth (and maybe in drillholes too). The desired aim is to use the observed TMI data to determine the distribution of susceptibility in the earth. The aim being that this distribution helps to define the geological structures from which prospective mineralized targets can be identified and drilled.

One of the simplest approaches to solving this inverse problem is to use a simple geometrical body (eg thin sheet, thick sheet, ellipsoid etc) for which the forward problem is easy to solve and modify the parameters of the body (eg susceptibility, thickness, dip etc) until the response for the simple body is close to the observed response. In many cases such simple models are more than adequate for explaining the observed data and identifying a target for drilling. 
Once adequate computer power became available, this process was automated using a variety of methods to automatically find the model parameter values which gave the best fit to the observed data.

However, in some cases the observed data is quite complex and no simple body or bodies will be adequate to explain the observed data. Such cases generally arise where the underlying structures are truly 3 dimensional. The desire to solve such problems led to the UBC forming the GIF consortium to develop methods which could be used to solve real-world problems.

For mag3d, the basic structure used by the UBC was to define a rectangular prism which is split into regular cells in the x, y and z directions with each cell having a constant susceptibility value. The real-world inverse problem is thus replaced by a simpler one of finding the distribution of susceptibility values for each cell for which the magnetic response calculated for the full model matches the specified observed data values.
This formulation of the problem clearly precludes any manual process of modifying individual cell susceptibility values to match the observed data since the number of cells in a reasonably sized model is simply too large. The methods used for parameter fitting of simple geometric bodies could not be easily applied since in this formulation, the number of unknown values (ie the cell susceptibility values) was much larger than the number of observed data and overall the number of knowns and unknowns was significantly larger.
Further problems arose because it is well known that there is no unique solution to this inverse problem. There are many possible distributions of susceptibility which can adequately explain the observed TMI readings eg the equivalent source process fits any number of observed data points using a single layer of magnetic dipoles.

The solution that the GIF consortium adopted combined a number of methods from fields such as optimization, linear algebra and numerical analysis to construct a software package to solve the inverse 3d mag problem.

The solution is best understood as follows:

The aim is to construct a mesh M and find a distribution of susceptibility over the mesh S(M) for which the TMI calculated at the observed data points TMI(D) agrees with the observed TMI data OBS(D). The term “agrees” here is entirely subjective, but in almost all cases it is formalized using the sum of squares measure of distance ie:
||TMI(D)-OBS(D)|| = (i (TMI(di)-OBS(di))2
Obviously the smallest value that this distance term can have is zero, so the aim is to find S(M) which minimizes this distance (Note that this distance term is also referred to as the data misfit, the norm, Euclidean distance or L2 norm). One obvious problem with defining the distance measure in this way is that it does not take into account the errors associated with each of the observed data points. If used as specified above, any method used to solve the problem may produce a model which fits noisy data values very well while only producing poor fits to good data values. To overcome this problem, the distance term is modified as follows:
||TMI(D)-OBS(D)|| = (i ((TMI(di)-OBS(di))/ERR(di))2
where ERR(di) is an estimate of the uncertainty in the observed data value. With this formulation, data points with large errors can have a correspondingly large data uncertainty assigned to them so that they will not adversely affect the overall minimization process.
As noted above, a straightforward attack on this problem of minimizing the data misfit may not give a meaningful solution since there is nothing to stop the solution process putting all the susceptibility in the surface layer of cells and there is nothing stopping the method from using negative susceptibility values.
Preventing the method from using negative susceptibilities is quite common in optimization and is generally addressed using barrier function methods. In such methods, a term is added to the data misfit term which increases rapidly in amplitude as the parameter values approach invalid (ie negative) values. There a number of methods in use, and UBC chose the most common log barrier term. The log barrier function term is 
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Where the sum is taken over all susceptibility values in the model. So instead of just minimizing the data misfit, the problem is instead modified to minimize


||TMI(D)-OBS(D)|| + 2( BARR

and ( is chosen to be a small number to ensure that the solution is predominantly controlled by the data misfit term.

This still does not address the difficulty that there is nothing to stop the solution placing all the susceptibility in the surface cells with appropriate variations in neighbouring cells to fit the observed data. Such a solution is perfectly feasible, but is not very likely in the real world. Generally, if a portion of the real world was divided up into cells such as those used in mag3d, the susceptibility of any single cell is highly likely to be correlated with those around it. There are many possible ways to incorporate this geometrical constraint that neighbouring cells should have similar values and such methods are broadly categorized as regularization methods.

The approach adopted by UBC was twofold: they aimed to construct a solution which was smooth in the x, y and z directions and they also aimed to build a solution which was near to some specified reference model. So, using the same framework as the data misfit, the problem is further modified so that the aim is to minimize

((S) = ||TMI(D)-OBS(D)|| + 2( BARR + ( ((s ||S(M) – R(M)|| + (x ||(x(S(M) – R(M))|| + 

(y ||(y(S(M) – R(M))|| + (z ||(z(S(M) – R(M))||)

where R(M) is a distribution of susceptibilities for a fixed reference model and
||S(M)-R(M)|| = (ijk(mijk-rijk)2
and the (x , (y  and (z are differentiation operators in the x, y and z directions respectively. In simpler terms the aim is to find a model which minimizes the data misfit subject to all susceptibility values being positive and the model being close to a specified reference model and which is as smooth as possible. 

Note that the positivity constraint is absolute: the method cannot give any negative susceptibility values. However the smoothness terms are not absolute: the method can give arbitrarily rough models if that is dictated by the data misfit term (though this depends on the choices for (, (s, (x, (y and (z).
With this formulation of the problem, it is now possible to apply standard methods to find a model S(M) which minimizes ((S), and with appropriate choices of  (,  (, (s, (x, (y and (z the resulting solution will be purely positive, smoothly varying and will fit the data.
The problem of minimizing ((S) is still not simple as it is a non-linear problem. The approach taken by UBC to solve this is to apply the standard optimization Gauss-Newton approach which linearizes the problem about the current estimate of the solution and modifies the current model parameters in the direction of the gradient in order to reduce the value of the objective function. There are of course many practical problems with implementing this process, but it basically involves solving a large system of linear equations which depend on the results of calculating multiple forward modeling problems, so the problem is now quite tractable using currently available computers.
The story does not end here since the research carried out by UBC showed that even with all these parameters, the solution process still tended to give models in which the susceptibility was concentrated in the shallower parts of the model. To overcome this they added a depth weighting term in the calculation of the norms involving the model. This depth weighting boosts the importance of the deeper cells in the model to the model norm components and so forced the inversion process to push the susceptibility deeper than it would otherwise do.
UBC mag3d
Mag3d inversion processing sequence
1. Decide the area of interest and establish the type of target

2. Assemble data for the area of interest and check it to ensure that all bad data has been removed

3. Establish the desired data misfit for the observed data

4. Determine the magnetic field inclination, declination and field strength for the time when the data was collected

5. Check any elevation and topographic data to be used and eliminate any bad data

6. Decide the mesh cell sizes and total depth of interest and construct the required mesh

7. Select the relevant observed data points to be used in the inversion and remove any background base level from the data

8. Run magsen3d with the mesh, data and topo files and shift or remove any data points which cause magsen3d to fail

9. Determine a best guess at the inversion parameters to use, set up the required input file
10. Run maginv3d and check the results to ensure that the inversion has fitted the data reasonably well and that the model is reasonable.
11. Modify the inversion parameters as required in order to improve the data fit and/or generate a more reasonable solution

12. Repeat steps 10 to 12 (and maybe also revisit steps 1 to 9) until you achieve a reasonable solution.

Observed Data
1. If the area of interest does not line up with the xy axes, transform the data so that it can be covered with a smaller mesh (but don’t forget to apply the same transformation to the magnetic declination).

2. Grid the data to assess the noise level in the data

3. Remove all bad data/lines/tie lines from the survey and re-grid

4. Decide whether to use point data or gridded data for the inversion. Point data may be better for areas with strong topographic relief.

5. If using point data it is best to use diurnally corrected raw data together with the actual sensor elevation.

6. If using gridded data, use the diurnally corrected, IGRF removed leveled data and set the sensor elevation to the average terrain clearance.

7. If there are strong level differences in the raw point data which are not predominantly due to flying elevation differences, you are better off using gridded leveled data.

8. Determine the IGRF field for the centre of the survey area for the time that the data was collected.

9. Determine the background level for the observed data in the area of interest. This can be done by calculating a forward model for the target body type and calculating the ratio of the maximum to minimum response. Pick the maximum and minimum for the anomaly of interest in the observed data and pick the background level using the ratio from the theoretical model. If there is no obvious target body type, use the thin or thick sheet Excel spreadsheets to give an estimate.

10. If there is a significant regional gradient in the area of interest, calculate a residual fiend value by upward continuing the observed data to a height which is the same as the deepest structure of interest and subtract the continued data from the observed data. The background level for the residual data should be zero, but check to make sure.

11. If the observed data is particularly noisy, upward continue the data to reduce the noise. Don’t forget to add the upward continuation to the sensor elevation.

12. Assign a data uncertainty commensurate with the noise in the observed data. Generally a level of 1% of the data value + 1 nT gives a reasonable uncertainty, but a smaller percentage term may be required when fitting highly magnetic features.

13. Check that any altimeter and DTM data are coherent by gridding the DTM data calculated from the sensor elevation (eg GPS height- radar altimeter). If there is a strong line effect, level or smooth the DTM data and calculate the sensor elevation by adding the sensor height to the resulting DTM.

14. Include as much of the anomaly of interest as possible in the area to be inverted

15. Decide whether to include topography in the inversion. If the topographic relief is small relative to the lateral size of the grid cells being used, there is little point in including the topography. 

Mesh Design

1. Generally use uniform cells in the x, y and z directions for the core region covering the area of interest.

2. Can use cells which increase in thickness with depth

3. Generally add 4 padding cells at each side and at the bottom of the mesh which are 1, 2, 4 and 8 times the core cell size

4. Cell size is chosen to be small enough to adequately define the structures of interest but not produce a sensitivity matrix which is too large to fit within memory. As an approximation, the uncompressed sensitivity matrix is approximately 

5. Nobs x Mx x My x Mz x 4 bytes 

6. With a wavelet compression factor of C, the matrix size is approximately

7. Nobs x Mx x My x Mz x 4 x C/2  bytes 

8. Often it is best to run a regional inversion with a mesh of about 40 x 40 x 30 cells to determine the best parameters to use for the inversion

Topography data

The topography data does not need to be specified at the same locations as the observed data, but it is generally preferable to do so. The program handles the topography data by forming a Delauny triangulation for the specified points and then flagging all cells in the model which are not completely beneath the triangulated surface. If the topo data is supplied it is best to cover the entire region defined by the mesh, but the program will accept topographic data which covers at least 40% of the total region.
If the topography has been specified, the observed data points are compared too the discretized topography to ensure that the data is above the surface. The program fails if any point specified as a surface data point is below the discretized surface. This can cause problems in areas of the mesh where there are strong gradients in the topography as data points can end up under the surface and the program does not tell you which point is causing the problem. If this happens, the point can be identified using a process of elimination on the observed data file or you can successively shift the mesh down by reducing the z origin value in the mesh file until the observed data is accepted.
Sensitivity matrix

This matrix simply contains a precomputed mag anomaly at each of the data locations used in the inversion for each of the cells in the model. The calculations of the response at the observed locations for a given distribution of susceptibility in the model from scratch is a time consuming operation, so having the values precomputed makes this process a lot faster at the expense of requiring a large amount of data to be stored (ie Nobs x Mx x My x Mz values).
Matrix Sensitivity calculation
1. Determine what depth weighting to use based on the weights Excel spreadsheet. Default depth weighting can result in models with almost no susceptibility in the surface layer.

2. Use distance weighting if there is strong topography in the inversion

3. Specify more accurate wavelet compression for low latitude inversions or if you get NS or EW “ribs” in your inverted model. This can be achieved by using lower eps value or by using higher order wavelets.

Sensitivity matrix Compression
To reduce the amount of storage required for the sensitivity matrix, a mathematical process using Wavelets is used to compress the matrix. This process is similar to the usual Fourier transform, but uses different basis functions. In Fourier transforms, the basis functions are sin and cos functions. The wavelet basis functions used are from the Daubechies or Symlet families illustrated below. 
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Figure 1 Daubecies wavelets orders 2 to 10
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Figure 2 Symlet wavelet functions orders 2 to 8
The process used in the compression is to transform the sensitivity sub-matrix for each data point using the specified wavelet transform. Then all coefficients below the specified threshold tolerance are dropped and the remaining coefficients stored in index format in the sensitivity matrix file. When the sensitivity matrix needs to be applied, the transformed coefficients are (implicitly) expanded, the inverse transform applied and the reconstructed sub-matrix applied to the current susceptibility distribution to give the required mag anomaly value. Note that this compression process does lose some information, so some care needs to be applied in choosing the wavelet and tolerance to use. The daub4 wavelet has proved reasonable in most cases, though higher order wavelets may be required in low magnetic latitudes. 
See the website http://www.mathworks.com/access/helpdesk/help/toolbox/wavelet/wavelet.shtml for more detailed information about wavelets.
Running the inversions
1. You will probably make multiple inversion runs with different inversion parameters, so make sure that you copy the full set of partial results (excluding the large mtx file) to a well named sub-directory so that you can revert to a previous set of parameters at some later stage. It can be surprisingly difficult to recover the parameters for a previous run if you use just one directory an update the inversion input files.

2. There are cases where the mag3d inversion process does not terminate correctly and will continue iterating with only marginal improvement in the data fit.. You can check for this by examining the end of the maginv3d.log file to see if the inversion has actually achieved the required misfit. If it has, the inversion process can safely be terminated (though it is safest to wait until just after the latest iteration is reported).

Convergence criteria
The program mag3d has multiple levels of iterations:
The solution of the system of linear equations uses conjugate gradient iterative method

The solution of the non-linear system uses a Newton type iteration

The line search for mode 1 successively updates the regularization parameter

Each of these iteration processes has its own stopping criteria:

Conjugate gradient iteration

This process stops if it reaches 500 iterations or if the relative change in an iteration is less than 0.01

Gauss Newton iteration
This process stops if it reaches 60 iterations, otherwise it continues if the relative change in the chi factor exceeds 0.1 or if the relative change in the total objective function exceeds 0.1 or if both the ratio of the barrier and model norms is greater than 0.05 and the latest chi factor has not decreased by at least 10% of the previous chi value.
Line search iteration
For mode 1 operation, the Newton iteration is performed until completion and the resulting chi value is compared with the target chi. If the relative difference is greater than the specified tolc value, a new regularization parameter is added to the current list. This process is terminated once five regularization parameters have been tested.

Practicalities
Computer crashes

If the computer crashes or program running needs to be interrupted while magsen3d is running, you should delete the partial mtx file and start again. If it happens while maginv3d is running, change the restart value (the first line of maginv3d.inp) from 0 to 1 and start again. When maginv3d restarts, it “warms” the final solution from the previous iteration by adding random noise to the susceptibility values and continues iterating from where it was terminated. 

If by bad luck the final solution file was not closed correctly and the file is incomplete, you can copy the maginv3d.kap file over the maginv3d.sus file and the program should continue. If maginv3d was interrupted while it was performing the initial line search or GCV calculations you need to start maginv3d from scratch.
Changing the mesh file

If you change the number of cells, the x, y or z origin or any of the cell sizes you have to delete the mtx file and start the inversion process again. You may also need to modify the observed data points as the program will not accept any data point which is on a mesh node.

Changing the depth weighting or wavelet compression
Changing any of these value necessitates deleting the mtx file and starting the inversion again

Changing the observed data
If you add or remove data points or change any of the data locations, you have to restart the entire process. If you change the data uncertainty, you can retain the existing mtx file but you need to start the maginv3d program from scratch. It is possible to resume iterating from the previous solution, but convergence may be slow or non-existent.
Changing the inversion parameters
The program maginv3d will not allow you to change the mode parameter and resume iterating. It does permit you to change the remaining parameters, but it is probably better to restart the inversion if you make any significant changes to any of the parameters.

Intermediate files
The program magsen3d does not generate any intermediate files or a log file. You should take note of the znot value and the expected compression value displayed on the screen when the program starts. The compression value lets you determine the expected size of the compressed sensitivity matrix file so that you can ensure that it will fit in the available system memory. The znot value is useful for determining the effects of the depth weighting used if you are interested and knowing the default value makes it easier to decide what value to specify if you want to specify your own value.

The program maginv3d updates multiple files as it is iterating. The file maginv3d.kap contains the current model used by the program. In the initial line search stage for the mode 1 inversion, the susceptibility values in this file can be negative. Once the iteration process is running, the kap file will contain a positive model, so if the inversion process is terminated other than by normal program exit, the kap file can be used as a model. The program also updates the maginv3d.pre file when it writes out the kap file, so it can also be examined to see how well the current model is fitting the data.
While maginv3d is running it updates the maginv3d.log and maginv3d.aux files with the latest information on the convergence of the solution, model norms and achieved misfit. By monitoring these files and the examining the model in the kap file, you can terminate the iterations once you believe that a reasonable solution has been obtained and further iterations will not be worthwhile.

Case Study: Olympic Dam
The mag3d\OlympicDam\data\flightline directory on the CD contains a subset of a n aeromag survey which covers the Olympic Dam deposit in South Australia. Start WinDisp, select the Post Data from a Text File option, click OK, navigate to this directory and select the file odarea-tmi.csv. Set the First Line with Data value to 2 and the Line with Data Names to 1 and click on Check Format and then Done. Click on Done on the Specify Names form and then OK on the Posting Style form to select Value Posting style. Select X and Y as the x and y data variables, click on OK and then select the Z column as the data to be posted. Click on the Display Data Range button to read the data file and click on the Copy Limits > To Plot Limits menu item to define the area to be displayed and select the desired map scale. Click on Done and then on the Define Data variable button and change the Label Size to 0. Then click on Done, OK and then display and you will see a map of the flight line data:
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There is a potential problem here as there are overlapping lines in the survey. To see if this is a problem, click on the Edit> Posting> Edit Posting Specifications menu item, then click on the Display Data Range button again. Set the grid cell sizes to 100, the search radius to 0, the Output grid file name to odarea-tmi.grd and the output format to Geosoft Binary.
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Once the data has been gridded, click on the Grid Data button, click on Done, OK and then the Edit Images menu item, select the odarea_tmi.grd file, select Colour Sun Illumination as the Display style, click on Done and then on Display and you should see the following map:
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The image looks reasonable, but to see what it looks like without the data, click on the Edit> Display List menu item, turn off the Frame and Data Posting check boxes and click on the Select button and then Display again. The image display now should look like this:
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There are some line leveling effects visible, but these are fairly minor so we do not really need to do any work to improve the data.

There is no topography or sensor elevation in the data file, but this area is quite flat, so there is no need to include topography in the inversion.

IGRF for this region

To invert this data, we need to determine the IGRF field parameters for this location which required the geographic coordinates of the survey and the survey flight date. To get the geographic coordinates we need to convert the AMG53 coordinate to latitude and longitude. To do this, click on the Edit> Area limits, Scale and Projection menu item, select Australian Map Grid as the projection and specify 53 as the zone number. Then click on the Geographic limits tab and note the minimum and maximum latitude and longitude values. The centre of the area is about 136 55E, 30 25S.
Start the program IGRFPT in the igrf_usgs directory and enter the required information. I don’t know the survey date, so enter 1995 180 to represent halfway through 1995. Then enter -30.4 as the latitude and 136.9 as the longitude and 300 as the surface elevation (above sea level). The resulting field values are:

   total field       inclination      declination

      57379.20         -63.37           6.66

These values are slightly different from the values I’ve used in the inversions (as I did not record the date that I used), but the difference is relatively small and should not be too significant.
Determining the background level

In order to determine the background level to remove from the data, first click on the Edit> Images menu item and then on the Display Histogram button. To get the following histogram form and note the minimum, maximum and the average and variance of the data. The most useful value is the average as for this survey location it is probably a reasonable value for the background.
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Next click on the grid profiling tool (the second-last button on the toolbar) and click on the image to the south of the main anomaly, move the mouse direct north over the main peak and click again at the northern edge. Then press the esc key to end grid profiling and the grid profile will be displayed:
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Change the sample interval to 50, click on the Save button and save the profile in the file NS_profile.csv and give it an identifying line number of 10000. Then click on Done and then the Utilities> Profile Modeller menu item, select the csv file just created, click on the Load Locations button and enter the field values -63.6, 6.7 and 57490. Set the Residual Filter half-width to 0 and the sensor elevation to 40 and click on the Current Model tab. Double click in the centre of the bottom window to insert a thin sheet, change the body type to thick sheet. Play around with the body parameters and try adding new bodies to try fit the profile reasonably well.
[image: image10.png]=olx|

e todel
B (N oy — |
I~ Include Demag I Fix This Body
RockType [ _ Descrption
Property [ Value [Van[Min_ [Wax
| || [Bods Type ] Thick Smeet
| || [East 6811330
Noth 66307950
Distancs—[5394.4 Yes
1] ree AT50 Yes
2 Strike. -90.0 No
Do 121 ves
Widh (5398 Yes
Depth Bt |20850 Mo
gy Dens 100 ves
5o 0000 Yes
Rend 00 No
Remi 00 No
il [
Deteto this body | __Pertorm Inverson
——— Top Depth Suse
u. ll step [ Broart
o s 5 B E

Width ¢ >

7 - B [ —— o i
Data Definins Current Model suke «f [ o] o |

HiodelVertcal ieloh 100 Tearioe =D Tizot1 26 T





It should be reasonably clear that the profile can’t be fully modeled using just simple bodies, but you can get quite a reasonable fit to the main features. This process does seem to indicate that the main feature of interest is dipping at about 130 degrees.
If we use the base level of 3064 for this profile, the inversion will have great difficulty fitting the fall-off of the observed data at the south and northern ends of the profile. So I chose to use a lower level of 2800 as the background for the first stage of the inversion.
The thick_sheet Excel spreadsheet on the CD can be used to estimate the background level when the features of interest are near vertical, but this does not appear to be the case for this dataset.

Setting up the inversion using the observed data
There is now enough information to set up the inversion, so click on close the profile modeler (if it is still open) and click on the 3D Models menu item, then click on the Create> Simple inversion menu item on the 3DModeller form to bring up the UBC 3D inversion utility. You can fill in all the required parameters, but to make things simpler, click on the File> Read Parameter File> All Definitions menu item and load the file od_data_inversion.inp. Check out the relevant settings and then click on the Create Inversion tab, enter data_run as the directory name and click on the Create Inversion Files button and the inversion will be created.
If you check the Observed Data tab, you will see that the source of the data for this inversion is the original flight-line data file. This data is sampled at about 50m along the line and about 250m while the mesh being used for the inversion has cells which are 500x500. It is possible to use all of the data points in the inversion but there is little point as the large cells cannot fit the high-frequency content in the observed data. The UBC manual recommends upward continuing the data to an elevation commensurate with the cell size. An alternative approach which I have adopted is to limit the data used to that observed data point which is closest to the centre of each of the cells (in plan view). This approach is reasonable if the data does not have much noise. If there is a high noise level, it is adviseable to upward continue the data to reduce the impact of the noise before it is used in the inversion.
Setting up the inversion using gridded data
The UBC 3D inversion utility can also be used to set up the inversion using gridded data. Click on the File> Read Parameter File> All Definitions menu item and load the file od_grid_inversion.inp and then click on the Observed data tab and you will see that instead of the previous csv file, the form now displays the TMI grid file. Click on the Create Inversion tab, enter grid_run as the directory name and click on the Create Inversion Files button and the inversion will be created.

Inverting the gridded data
Now that the inversion files have been created, the magsen3d and maginv3d programs can be invoked to run the inversion. To make life easier, WinDisp also writes out a regional.bat file which calls the inversion programs and then calls the UBCError utility to create a data file which contains the observed, predicted, difference and Z-scores for the data being inverted. The utility also grids these values to make it easy to see how well the inversion has worked in fitting the observed data.
Sample inversion runs
To help understand the effects of the various parameters on the resulting inverted model, the CD contains an inversion directory with a number of different runs with different parameters. Some of the results for these inversion runs are described in the following pages. For each of the runs, the first page contains information on the parameters used and the second page displays images which show the data fit and the resulting model as both depth slices and as an isosurface.

Olympic Dam mag3d inversion run 1
Data: grid file
Depth weighting: default (3, 254.3)
Regularization:  User specified   0.1, 0.02

Alphas: 0.000001 1 1 1

Number of data: 896
Number of iterations: 56

Achieved chi: 0.07
Aux output:
1             !! Solution stage

 2  0.1000E+00 !! mode, chifact/amu0

 0             !! Number of multipliers tested (multiplier, misfit, norm)

  0.100000E+00 !! Current multiplier

  0.000000E+00 !! Estimated slope

  0  0         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.339460E+07  0.160212E+01  0.279963E+06  0.121252E+02

   1  0.320121E+07  0.215732E+01  0.277181E+06  0.107049E+02

   2  0.265916E+07  0.791679E+01  0.270086E+06  0.750570E+01

   3  0.120315E+07  0.149375E+03  0.254984E+06  0.274186E+01

   4  0.819326E+06  0.230721E+03  0.249282E+06  0.216151E+01

   5  0.685568E+06  0.346348E+03  0.246679E+06  0.195042E+01

  .

  .

  51  0.912655E-01  0.974236E+03  0.184806E+06  0.471214E-05

  52  0.848123E-01  0.955402E+03  0.184955E+06  0.452442E-05

  53  0.826862E-01  0.949457E+03  0.185040E+06  0.446250E-05

  54  0.746984E-01  0.920802E+03  0.185335E+06  0.417481E-05

  55  0.731025E-01  0.916004E+03  0.185413E+06  0.411597E-05

  56  0.723776E-01  0.913584E+03  0.185430E+06  0.409150E-05
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 Figure 3 Inversion results
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Figure 4 Susceptibility at -125RL 

Figure 5 Susceptibility at -1125 RL
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Figure 6 30000x10^-6 SI isosurface

Olympic Dam mag3d inversion run 2
Data: grid file
Depth weighting: 3, 2000
Regularization:  Line search 1, 0.02

Alphas: 0.000001 1 1 1

Number of data: 896
Number of iterations: 38

Achieved chi: 860
Aux output:
1             !! Solution stage

 1  0.1000E+01 !! mode, chifact/amu0

    0.8960E+03 !! target misfit

 3             !! Number of multipliers tested (multiplier, misfit, norm)

  0.658624E+02  0.819606E+03  0.216684E+03

  0.104116E+03  0.173911E+04  0.205577E+03

  0.473191E+03  0.155795E+05  0.151908E+03

  0.695338E+02 !! Current multiplier

  0.164282E+01 !! Estimated slope

  0 -1         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.148570E+04  0.218152E+03  0.183524E+06  0.907492E-01

   1  0.129012E+04  0.218872E+03  0.182073E+06  0.744438E-01

   2  0.915764E+03  0.221531E+03  0.178382E+06  0.297316E-01

   3  0.878236E+03  0.220960E+03  0.178239E+06  0.208105E-01

   4  0.853970E+03  0.219812E+03  0.179022E+06  0.968792E-02

   5  0.860710E+03  0.217844E+03  0.183086E+06  0.443908E-02
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Figure 7 Inversion results
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Figure 8 Susceptibility at -125RL 

Figure 9 Susceptibility at -1125 RL
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Figure 10 30000x10^-6 SI isosurface

Olympic Dam mag3d inversion run 3
Data: grid file
Depth weighting: 3, 2000
Regularization:  User specified  0.1, 0.02

Alphas: 0.000001 1 1 1

Number of data: 896
Number of iterations: 32

Achieved chi: 0.02
Aux output:
1             !! Solution stage

 2  0.1000E+00 !! mode, chifact/amu0

 0             !! Number of multipliers tested (multiplier, misfit, norm)

  0.100000E+00 !! Current multiplier

  0.000000E+00 !! Estimated slope

  0  0         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.339219E+07  0.126262E+01  0.229698E+06  0.147680E+02

   1  0.318233E+07  0.180412E+01  0.226284E+06  0.126308E+02

   2  0.261539E+07  0.631874E+01  0.218273E+06  0.835053E+01

   3  0.950724E+06  0.141736E+03  0.200343E+06  0.162247E+01

   4  0.644443E+06  0.265453E+03  0.194929E+06  0.128612E+01

   5  0.403373E+06  0.949881E+03  0.189334E+06  0.988540E+00

   6  0.248162E+06  0.169872E+04  0.183954E+06  0.755770E+00

  .

  .

  55  0.290657E-01  0.283628E+03  0.167359E+06  0.281730E-04

  56  0.263864E-01  0.281566E+03  0.168038E+06  0.262677E-04

  57  0.251086E-01  0.280600E+03  0.168273E+06  0.253715E-04

  58  0.228283E-01  0.278144E+03  0.169052E+06  0.236489E-04

  59  0.211343E-01  0.276701E+03  0.169446E+06  0.224758E-04

  60  0.194545E-01  0.275146E+03  0.170026E+06  0.210565E-04

  32  0.910292E+00  0.449170E+03  0.150378E+06  0.190298E-03
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Figure 11 Inversion results
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Figure 12 Susceptibility at -125RL 

Figure 13 Susceptibility at -1125 RL
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Figure 14 30000x10^-6 SI isosurface

Olympic Dam mag3d inversion run 4
Data: grid file
Depth weighting: 3, 2000
Regularization:  User specified  1, 0.02

Alphas: 0.000001 1 1 1

Number of data: 896
Number of iterations: 22

Achieved chi: 1.9
Aux output:
1             !! Solution stage

 2  0.1000E+01 !! mode, chifact/amu0

 0             !! Number of multipliers tested (multiplier, misfit, norm)

  0.100000E+01 !! Current multiplier

  0.000000E+00 !! Estimated slope

  0  0         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.339219E+07  0.126262E+01  0.229698E+06  0.147680E+02

   1  0.318232E+07  0.180403E+01  0.226284E+06  0.126307E+02

   2  0.261535E+07  0.631659E+01  0.218272E+06  0.835018E+01

   3  0.962050E+06  0.137226E+03  0.200469E+06  0.169200E+01

   4  0.630468E+06  0.250093E+03  0.194651E+06  0.131203E+01

   5  0.300184E+06  0.932574E+03  0.186614E+06  0.857019E+00

  .

  .

  18  0.585999E+01  0.320887E+03  0.157689E+06  0.115616E-02

  19  0.420320E+01  0.306629E+03  0.159436E+06  0.929952E-03

  20  0.299195E+01  0.294067E+03  0.161363E+06  0.733542E-03

  21  0.252349E+01  0.288283E+03  0.162427E+06  0.646565E-03

  22  0.193467E+01  0.280142E+03  0.164233E+06  0.521883E-03
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Figure 15 Inversion results
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Figure 16 Susceptibility at -125RL 

Figure 17 Susceptibility at -1125 RL
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Figure 18 30000x10^-6 SI isosurface

Olympic Dam mag3d inversion run 5
Data: grid file
Depth weighting: 3, 2000
Regularization:  GCV   1, 0.02

Alphas: 0.000001 1 1 1

Number of data: 896
Number of iterations: 18

Achieved chi: 1724.9
Aux output:
1             !! Solution stage

 3  0.1000E+01 !! mode, chifact/amu0

 0             !! Number of multipliers tested (multiplier, misfit, norm)

  0.103622E+03 !! Current multiplier

  0.000000E+00 !! Estimated slope

  0  0         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.339219E+07  0.126262E+01  0.229698E+06  0.147686E+02

   1  0.318104E+07  0.179583E+01  0.226265E+06  0.126160E+02

   2  0.261075E+07  0.616025E+01  0.218211E+06  0.830955E+01

   3  0.914304E+06  0.109546E+03  0.199849E+06  0.135498E+01

   4  0.456863E+06  0.126584E+03  0.191699E+06  0.867085E+00

   5  0.164656E+06  0.163768E+03  0.181812E+06  0.450391E+00

  .

  .

  .

  14  0.191481E+04  0.205205E+03  0.187485E+06  0.348320E-02

  15  0.182221E+04  0.205413E+03  0.191387E+06  0.192159E-02

  16  0.176716E+04  0.205572E+03  0.195923E+06  0.938588E-03

  17  0.173568E+04  0.205684E+03  0.201800E+06  0.352858E-03

  18  0.172487E+04  0.205727E+03  0.206918E+06  0.147469E-03
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Figure 19 Inversion results
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Figure 20 Susceptibility at -125RL 

Figure 21 Susceptibility at -1125 RL
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Figure 22 30000x10^-6 SI isosurface

Olympic Dam mag3d inversion run 6
Data: grid file
Depth weighting: 2, 1000
Regularization:  User specified   0.1, 0.02

Alphas: 0.000001 1 1 1

Number of data: 896
Number of iterations: 48

Achieved chi: 0.02
Aux output:
1             !! Solution stage

 2  0.1000E+00 !! mode, chifact/amu0

 0             !! Number of multipliers tested (multiplier, misfit, norm)

  0.100000E+00 !! Current multiplier

  0.000000E+00 !! Estimated slope

  0  0         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.339052E+07  0.126083E+01  0.229395E+06  0.147803E+02

   1  0.318148E+07  0.179562E+01  0.225986E+06  0.126485E+02

   2  0.260565E+07  0.640208E+01  0.217881E+06  0.829759E+01

   3  0.947403E+06  0.137765E+03  0.200069E+06  0.166963E+01

   4  0.662306E+06  0.246998E+03  0.195009E+06  0.134766E+01

   5  0.475480E+06  0.712132E+03  0.190785E+06  0.111924E+01

  .

  .

  45  0.291722E-01  0.469333E+03  0.157638E+06  0.423700E-04

  46  0.269237E-01  0.456560E+03  0.158195E+06  0.405980E-04

  47  0.240009E-01  0.438283E+03  0.159068E+06  0.380635E-04

  48  0.232511E-01  0.433529E+03  0.159289E+06  0.374022E-04
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Figure 23 Inversion results
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Figure 24 Susceptibility at -125RL 

Figure 25 Susceptibility at -1125 RL
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Figure 26 30000x10^-6 SI isosurface

Olympic Dam mag3d inversion run 7
Data: grid file
Depth weighting:   1 50
Regularization:  User specified   0.1, 0.02

Alphas: 0.000001 1 1 1

Number of data: 896
Number of iterations: 48

Achieved chi: 0.02
Aux output:
1             !! Solution stage

 2  0.1000E+00 !! mode, chifact/amu0

 0             !! Number of multipliers tested (multiplier, misfit, norm)

  0.100000E+00 !! Current multiplier

  0.000000E+00 !! Estimated slope

  0  0         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.339052E+07  0.126083E+01  0.229395E+06  0.147803E+02

   1  0.318148E+07  0.179562E+01  0.225986E+06  0.126485E+02

   2  0.260565E+07  0.640208E+01  0.217881E+06  0.829759E+01

   3  0.947403E+06  0.137765E+03  0.200069E+06  0.166963E+01

   4  0.662306E+06  0.246998E+03  0.195009E+06  0.134766E+01

   5  0.475480E+06  0.712132E+03  0.190785E+06  0.111924E+01

  .

  .

  45  0.291722E-01  0.469333E+03  0.157638E+06  0.423700E-04

  46  0.269237E-01  0.456560E+03  0.158195E+06  0.405980E-04

  47  0.240009E-01  0.438283E+03  0.159068E+06  0.380635E-04

  48  0.232511E-01  0.433529E+03  0.159289E+06  0.374022E-04
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Figure 27 Inversion results
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Figure 28 Susceptibility at -125RL 

Figure 29 Susceptibility at -1125 RL
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Figure 30 30000x10^-6 SI isosurface

Olympic Dam mag3d inversion run 8
Data: grid file
Depth weighting: 0
Regularization:  User specified, 1, 0.02
Alphas: 0.000001 1 1 1

Number of data: 896
Chieved chi: 3.1

Aux output:
Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.337172E+07  0.696725E+01  0.198943E+06  0.169482E+02

   1  0.317193E+07  0.917639E+01  0.195218E+06  0.143095E+02

   2  0.260176E+07  0.206423E+02  0.186397E+06  0.893667E+01

   3  0.120766E+07  0.174324E+03  0.170527E+06  0.299426E+01

   4  0.887980E+06  0.298773E+03  0.165787E+06  0.247713E+01

   5  0.555596E+06  0.868564E+03  0.159889E+06  0.188918E+01

   .

   .

  31  0.284937E+02  0.957683E+03  0.148246E+06  0.792362E-03

  32  0.169363E+02  0.939826E+03  0.150781E+06  0.598850E-03

  33  0.918094E+01  0.923492E+03  0.153857E+06  0.421811E-03

  34  0.603455E+01  0.914192E+03  0.156105E+06  0.321584E-03

  35  0.435018E+01  0.907682E+03  0.158150E+06  0.248362E-03

  36  0.309135E+01  0.900732E+03  0.161340E+06  0.163610E-03
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Figure 31 Inversion results
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Figure 32 Susceptibility at -1125RL 

Figure 33 Susceptibility at -125 RL
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Figure 34 30000x10^-6 SI isosurface

Discussion

These results show a sample of runs for inverting the gridded data using different depth weightings, different inversion modes and different chi values. There are many other possible parameter variations which could have been investigated, but these runs demonstrate the major items of interest in setting up most inversions. The UBC GIF have published some comparisons of the effect of varying the alpha parameters.

What is immediately obvious from these runs is that almost all the inversions do a reasonable job of modeling the observed data. except for runs 2 and 5. These runs were for line search mode and GCV mode respectively. However, even though the overall misfit for these runs is quite large, the central part of the main anomaly is fitted quite well. 
When the isosurfaces for these models are compared, they all show qualitative similarities except for the model generated in run 8. This run used no depth weighting and it can be seen that the susceptibility is much shallower than the other models. This model has not fitted the observed data so well at the peak of the anomaly, and the achieved chi value is 3.1.
The next worse model in terms of the achieved misfit is model 4 for which the achieved chi value is 1.9. This model also failed to fit the peak amplitude of the anomaly.
The remaining models all achieved or bettered the target misfit of 1, but all have generated models which have some commonalities, but which are quantitatively quite different models to explain the observed data. The model using the default depth weight has a core pipe-like body in the shallower part of the model but has a broad skirt of susceptible material in the deeper parts. The remaining runs all have a similar pipe-like structure going to depth with a dip which is broadly consistent with that found in the profile modeler. As the power of the depth weight factor decreases from 3 to 0, this structure becomes weaker at depth as the influence of the depth weighting term declines as power is reduced.
The following graph displays the size of the depth weighting term as a function of depth for the parameters used in the sample runs.
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This graph clearly shows the very strong depth weighting that is applied when the default is used. At the deepest parts of the model the cells have almost 100 times the influence that surface cells have. This is somewhat moderated because the anomalous value at the surface from such deep cells is much weaker than that for surface cells, but it is still a very strong factor driving the inversion and the results for run 1 show the effect that this has.

The depth weighting for 3, 2000 and 2, 1000 are really quite similar and the models generated (run 3 and run 6) are mostly quite similar. The model for run 3 has more susceptibility in deeper parts of the model than does the model for run 6 and this reflects the larger amplitude for the 3, 2000 weights at depths greater than 3000m.

The depth weighting for 1, 50 is somewhere between the default weights and the 3, 2000 and 2, 1000 weights and is similar in amplitude to the latter weights at depth. The resulting model reflects this as there is some susceptibile material at depth, but the the isosurface actually closes off at depth.
If we examine the weight values displayed in the following table, it is apparent that the default and 1, 50 weights show a large jump between the first and second depth cells. This large jump means that susceptibility is more likely to be placed into the second and subsequent layers than it is in the first. This effect can be seen in the model runs as the models generated in runs 1 and 7 are both closed at the top.
	nodes
	Default weights
	Weight 3, 2000
	Weight 2, 1000
	Weight 1, 50

	0
	1
	1
	1
	1

	250
	2.302821646
	1.182382
	1.224744871
	1.719312756

	500
	3.879673039
	1.374596
	1.449137675
	2.186763437

	750
	5.692673999
	1.576166
	1.673320053
	2.566896311

	1000
	7.715473833
	1.786679
	1.897366596
	2.896446836

	1250
	9.92873417
	2.005772
	2.121320344
	3.191673494

	1500
	12.31755829
	2.233121
	2.34520788
	3.461570407

	1750
	14.87003886
	2.468439
	2.569046516
	3.711756286

	2000
	17.57638493
	2.711464
	2.792848009
	3.94602709

	2250
	20.42836542
	2.961961
	3.016620626
	4.167092848

	2500
	23.41893678
	3.219713
	3.240370349
	4.376969691

	2750
	26.54198363
	3.484522
	3.464101615
	4.577206326

	3000
	29.79213201
	3.756205
	3.687817783
	4.769023322

	3250
	33.16461124
	4.034593
	3.911521443
	4.95340308

	3500
	36.6551491
	4.319527
	4.135214626
	5.131150329

	3750
	40.25989091
	4.610862
	4.358898944
	5.302934159

	4000
	45.767494
	5.053492
	4.69041576
	5.5482887

	4500
	57.31624664
	5.968876
	5.347896783
	6.006243632

	5500
	82.45196665
	7.916667
	6.648308055
	6.824739422


On balance, the models from runs 3 or 6 seem to be the most reasonable, and the model for run 3 will be used to illustrate the refinement process.
Inversion using data

To investigate the differences between using gridded data and point data, the inversion run 3 was set up using the original flight-line data and run again. As the following results show, the resulting model is almost identical with that produced by inverting the gridded data. The achieved chi was smaller, but it required more iterations to achieve the misfit.

Olympic Dam mag3d inversion – flight-line data
Data: observed data
Depth weighting: 3, 2000
Regularization:  User specified  0.1, 0.02

Alphas: 0.000001 1 1 1

Number of data: 890

Number of iterations: 52

Achieved chi: 0.01
Aux output:
1             !! Solution stage

 2  0.1000E+00 !! mode, chifact/amu0

 0             !! Number of multipliers tested (multiplier, misfit, norm)

  0.100000E+00 !! Current multiplier

  0.000000E+00 !! Estimated slope

  0  0         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.338002E+07  0.126262E+01  0.229698E+06  0.147150E+02

   1  0.318303E+07  0.178196E+01  0.226595E+06  0.127952E+02

   2  0.264467E+07  0.666124E+01  0.219160E+06  0.877636E+01

   3  0.107310E+07  0.190563E+03  0.202890E+06  0.245311E+01

   4  0.776609E+06  0.273544E+03  0.198029E+06  0.201175E+01

   5  0.552672E+06  0.618442E+03  0.193521E+06  0.165696E+01

  .

  .

  46  0.107282E-01  0.322665E+03  0.159643E+06  0.681019E-04

  47  0.995790E-02  0.315549E+03  0.160497E+06  0.605315E-04

  48  0.972427E-02  0.313803E+03  0.160770E+06  0.571431E-04

  49  0.996128E-02  0.309423E+03  0.161573E+06  0.524914E-04

  50  0.924989E-02  0.305011E+03  0.162184E+06  0.483638E-04

  51  0.912554E-02  0.301238E+03  0.162907E+06  0.437056E-04

  52  0.921250E-02  0.298966E+03  0.163293E+06  0.408229E-04
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Figure 35 Inversion results
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Figure 36 Susceptibility at -125RL 

Figure 37 Susceptibility at -1125 RL
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Figure 38 30000x10^-6 SI isosurface

Refinement process
It is readily apparent from these sample runs, that there is little detail in the inverted models because the cell sizes are so large. However, we cannot simply run an inversion using small cells since the size of the sensitivity matrix grows extremely rapidly as the number of cells and observed data points increases. This would not be a great problem for the current survey and it would be possible to use 250x250x125m cells on a reasonable computer. However the large model size does make the inversion process quite slow and it would not be feasible to run all of the sample runs using such a mesh.
Once a reasonable regional model has been established, the next stage is to refine the inversion in areas of interest to obtain more detail about the structure there. This process has been incorporated in WinDisp and proceeds as follows:

1. Load an existing inversion model into the 3D Model form

2. Build a tiled inversion for the existing model using the desired smaller cell sizes

3. Reassemble the tiles to form a small cell inversion for the entire area of interest

The tiling process was developed by UBC and works as follows:

1. The volume for the tile is nulled out in the overall refined model

2. The TMI response of the remaining shell is calculated at the points to be used for the tile inversion

3. This TMI response is subtracted from the observed TMI at the points to be used in the tile inversion to yield a residual TMI value
4. The part of the original model within the tile is used as a reference model to push the inversion to stay close to the model, but the model is permitted to change to fit the more detailed information in the observed data for the tile

To build a refined inversion, start WinDisp, start a new layout, click on the 3D Models menu item and load the mesh and model file form run 3 (located in the directory mag3d\OlympicDam\inversions\grid\weight_3_2000\mode_2_0.1 on the CD). Click on the Create> Refined inversion and load the od_grid_inversion.inp parameter file. Click on the Mesh tab, change the x and y cell sizes to 200 and the z cell size to 100. Change the maximum x tile size to 60 and the maximum y tile size to 50 and the tile overlap to 10. This will result in the current inversion model being refined to 88x78x44 cells (including padding) with the inversion broken up into a sequence of 9 tiles. The layout of these tiles can be viewed by selecting Total Region from the region to view and then clicking on the View mesh layout. It can be very useful to also load up the gridded TMI image so that the location of the tile boundaries can be fine tuned to ensure the best placement of the tiles relative to the main anomalies (that is why the maximum y tile size was set to be 50).
Before proceeding to set up the inversion, we need to examine the effect of the depth weighting for the new mesh. Open the weights Excel spreadsheet and examine the plots for the original mesh and the refined mesh with the 3, 2000 depth weighting. For the refined mesh, the depth scaling is the same as it was for the original mesh. If you now enter the value 109.3 for znot (which is the value chosen for default weighting), the maximum depth weighting increases from about 80 to something just over 200. Clearly this difference in the depth weighting will change the character of the refined inversion relative to that of the original inversion, so it is highly recommended that the weighting parameters for the refined inversion are explicitly specified to be consistent with what was used for the original inversion. However if exactly the same weighting is used the inversion becomes quite noisy and deep, so it appears that the changed cell size also needs to be taken into account. Since the new cells are smaller than the original cells (by a factor of 15.625), it appears that we need to increase the depth weighting accordingly, so znot has to be reduced to achieve this. In the sample refinement run I’ve set znot to be 200, which increases the amplitude of the weighting by a factor of about 16.
The next thing to change in the input file is the alpha S weighting term. Since we want the inversion to stay close to the original model, we need to make the alpha S term larger to penalize changes from the original model. A value of 0.01 is generally a reasonable starting value to try. Choosing the best value is difficult to do a priori because the impact of the various terms which are being minimized in the inversion is difficult to predict. The best way to approach this is to run the inversion on a representative tile, examine the resulting model to see that it fits the data and is reasonable. If it does not satisfy either or both of these conditions, examine the norm terms in the log file to decide whether to change the alpha S or one of the other inversion parameters. Once a reasonable solution has been obtained, copy the inversion input files to each of the tile directories and run the full tiled inversion using the run_all.bat file. Note that this batch file can be edited to reorganize the order that the tiles are processed, or to delete calls to tiles which are of no interest.
Once the refined inversion has been set up, save the parameter definitions and create the refined inversion using refinement_test as the directory name. 

Note that the program will not create a refined inversion if there are blanks in any of the directory names in the path for the current data. If this happens, copy the required original model and data files into a working directory, create the inversion and run it there. Once it is complete, the final results can be copied back to the original location.
I have not satisfactorily completed the full refinement process yet, but it seems that using an alpha_S value of  0.00001 and a chi value of 0.01 will give a reasonable inversion which is similar to the original inversion and also fits the data.
One thing to observe in the setting up of tiled inversions is the overlap between tiles. This is necessary as the cells at the edge of an inversion are less controlled by data than points in the centre of the mesh, so to get a reasonable match when stitching the tiles together, there needs to be a large number of overlapping cells. Have a look at the maginv3d.sns model in the sensitivity directory and you will see that the edge effect starts to decline at about 8 cells in, so 10 is a reasonable overlap to use. In some surveys, this overlap can be reduced to only 5 cells, whereas other surveys need more than 10 cells.

UBC grav3d
Case Study: Olympic Dam

The grav3d\OlympicDam\data directory on the CD contains the observed gravity data which covers the Olympic Dam deposit in South Australia. This data is a mix of a detailed survey and broader AGSO data. Start WinDisp and open the OD_detailedgrav layout and click on Display.
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This layout shows that there are some problem data points which should be removed before running the inversion. This is a bit of a tedious process in WinDisp, but I’ve already done it for you, so open the OD_detailedgravedit layout and click on Display
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This image is now much cleaner and is ready to be inverted.
Setting up the inversion using the observed data
There is now enough information to set up the inversion, so click on the 3D Models menu item, then click on the Create> Simple inversion menu item on the 3DModeller form to bring up the UBC 3D inversion utility. You can fill in all the required parameters, but to make things simpler, click on the File> Read Parameter File> All Definitions menu item and load the file od_data_inversion.inp. Check out the relevant settings and then click on the Create Inversion tab, enter data_run as the directory name and click on the Create Inversion Files button and the inversion will be created.
If you check the Observed Data tab, you will see that the source of the data for this inversion is the original csv data file. The error is set at 1% + 0.001 mGal and the background level has been set to -14.7. The background level is much more arbitrary in grav3d than in mag3d and represents the background density value for the resulting model. When grav3d is run without positivity (the most common mode), the densities returned are the contrast relative to the background density, which corresponds to the background level subtracted from the observed data. Unfortunately there is no way to determine what the actual background density is for a given mGal value used for the background data value, so all you can do is choose what looks to be a reasonable value, assess the inversion results and run the model again if required. The -14.7 value used is probably an underestimate since the real densities for Olympic dam are more than the contrast in the inversion model, but the resulting model is qualitatively reasonable.

Setting up the inversion using gridded data
The UBC 3D inversion utility can also be used to set up the inversion using gridded data. Click on the File> Read Parameter File> All Definitions menu item and load the file od_grid_inversion.inp and then click on the Observed data tab and you will see that instead of the previous csv file, the form now displays the gravity grid file. Click on the Create Inversion tab, enter grid_run as the directory name and click on the Create Inversion Files button and the inversion will be created.

Olympic Dam grav3d inversion run 1
Data: grid file
Depth weighting: default
Regularization:  User specified, 0.1

Lengths: 5000 5000 5000
Number of data: 649

Total iterations: 8
Achieved chi: 0.49
Aux output:
1             !! Solution stage

 2  0.1000E+00 !! mode, chifact/amu0

 0             !! Number of multipliers tested (multiplier, misfit, norm)

  0.100000E+00 !! Current multiplier

  0.000000E+00 !! Estimated slope

  0  0         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.540319E+07  0.000000E+00  0.351342E+05  0.153787E+03

   1  0.789326E+05  0.324733E+03  0.351645E+05  0.115340E+02

   2  0.209728E+04  0.581413E+03  0.351704E+05  0.865051E+00

   3  0.311329E+02  0.608307E+03  0.351640E+05  0.648788E-01

   4  0.121077E+01  0.585946E+03  0.351631E+05  0.486591E-02

   5  0.163541E+01  0.539209E+03  0.351624E+05  0.364943E-03

   6  0.488328E+00  0.532677E+03  0.351623E+05  0.273707E-04

   7  0.270794E+02  0.413178E+03  0.351573E+05  0.205280E-05

   8  0.232671E+02  0.415710E+03  0.351567E+05  0.153960E-06
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Figure 39 Inversion results
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Figure 40 Density at -100 RL 


Figure 41 Density at -1000 RL
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Figure 42 0.2 g/cc isosurface

Olympic Dam grav3d inversion run 2
Data: grid file
Depth weighting: 3, 2000
Regularization:  User defined 0.1, 0.02

Lengths: 5000 5000 5000
Number of data: 649

Total iterations: 26*
Achieved chi: 0.8
Aux output:
1             !! Solution stage

 2  0.1000E+00 !! mode, chifact/amu0

 0             !! Number of multipliers tested (multiplier, misfit, norm)

  0.100000E+00 !! Current multiplier

  0.000000E+00 !! Estimated slope

  0  0         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.540319E+07  0.000000E+00  0.351342E+05  0.153787E+03

   1  0.471302E+05  0.126626E+04  0.351519E+05  0.115340E+02

   2  0.582200E+03  0.148444E+04  0.351556E+05  0.865051E+00

   3  0.689008E+01  0.111242E+04  0.351491E+05  0.648788E-01

   4  0.118350E+01  0.106027E+04  0.351477E+05  0.486591E-02

   5  0.115681E+01  0.103842E+04  0.351470E+05  0.364943E-03

  .

  .

  21  0.725548E+00  0.101719E+04  0.351442E+05  0.365767E-21

  22  0.709053E+00  0.101730E+04  0.351442E+05  0.274325E-22

  23  0.724093E+00  0.101709E+04  0.351441E+05  0.205744E-23

  24  0.748209E+00  0.105995E+04  0.351449E+05  0.154308E-24

  25  0.756478E+00  0.105977E+04  0.351448E+05  0.115731E-25

  26  0.750052E+00  0.105978E+04  0.351448E+05  0.867981E-27
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Figure 43 Inversion results
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Figure 44 Density at -100 RL 


Figure 45 Density at -1000 RL
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Figure 46 0.2 g/cc isosurface

Olympic Dam grav3d inversion run 3
Data: observed data
Depth weighting: default
Regularization:  User specified, 0.1

Lengths: 5000 5000 5000
Number of data: 283

Total iterations: 18
Achieved chi: 20.3
Aux output:
1             !! Solution stage

 2  0.1000E+00 !! mode, chifact/amu0

 0             !! Number of multipliers tested (multiplier, misfit, norm)

  0.100000E+00 !! Current multiplier

  0.000000E+00 !! Estimated slope

  0  0         !! Status of line search

 Summary of the latest barrier iterations:

 iter  data misfit    model norm       barrier    new lambda

   0  0.250203E+07  0.000000E+00  0.351342E+05  0.712133E+02

   1  0.348578E+05  0.560256E+03  0.351632E+05  0.534100E+01

   2  0.672356E+03  0.192280E+04  0.351698E+05  0.400575E+00

   3  0.440201E+02  0.173014E+04  0.351626E+05  0.300431E-01

   4  0.207614E+02  0.170441E+04  0.351681E+05  0.225323E-02

   5  0.217692E+02  0.165959E+04  0.351705E+05  0.168992E-03

   6  0.197834E+02  0.166959E+04  0.351721E+05  0.126744E-04

   7  0.210472E+02  0.165176E+04  0.351719E+05  0.950582E-06

   8  0.199795E+02  0.165981E+04  0.351722E+05  0.712936E-07

   9  0.207756E+02  0.165011E+04  0.351716E+05  0.534702E-08

  10  0.201074E+02  0.165573E+04  0.351717E+05  0.401027E-09

  11  0.206553E+02  0.164938E+04  0.351710E+05  0.300770E-10

  12  0.201833E+02  0.165351E+04  0.351711E+05  0.225577E-11

  13  0.205795E+02  0.164904E+04  0.351705E+05  0.169183E-12

  14  0.202239E+02  0.165219E+04  0.351705E+05  0.126887E-13

  15  0.204916E+02  0.164917E+04  0.351700E+05  0.951654E-15

  16  0.202498E+02  0.165135E+04  0.351700E+05  0.713741E-16

  17  0.204592E+02  0.164903E+04  0.351696E+05  0.535305E-17

  18  0.202663E+02  0.165082E+04  0.351696E+05  0.401479E-18
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Figure 47 Inversion results
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Figure 48 Density at -100 RL 


Figure 49 Density at -1000 RL
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Figure 50 0.2 g/cc isosurface

Discussion
There are more inversion runs on the CD which explore different length scale parameters and different inversion modes and tolerances. The above three runs are reasonably illustrative of the range of models produced. In this case the 3, 2000 generates a model which comes too close to the surface and the default depth weighting is preferable. The model in run 3 generated by inverting the observed data shows a lot more structure than that generated in run 1 using the gridded data, but is quite similar in the shallower part of the volume.
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