WinDisp Workshop Feb 21, 2009
Exercise 1: Loading IP data from legacy data and Geosoft dat files 
Example of a simple text file that is not in Geosoft format (7900N.lst)
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Example of edited file which is now a valid Geosoft file:
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Geosoft dat file format:

Line 1: Title line

This line can contain any text useful for describing the survey

Line 2: Definition of survey
Line: should be the first field on the survey definition file and the line number can have a direction suffix of N,S,E or W.
Array: defines the survey array geometry. Valid types are:

DPDP: dipole-dipole

PLDP: pole-dipole

DPPL: dipole-pole

PLPL: pole-pole

GRD: or GRAD: gradient array

RIP: roving IP

DIPOLE: defines the standard dipole spacing for the survey. This is an indicative value only and is overridden by the actual Tx and Rx dipole spacings in the dat

UNITS: This defines the survey units. Valid values are:
M: meters

F: feet

The units field is not currently used in TQIPdb, so the values stored use the same distance units as in the data file. So it is important not to mix files using feet with files which use meters.

T: This defines the time windows used when collecting IP data. The first value is the offset (in ms) to the start of the first window. The remaining values specify the widths of the windows in ms. The number of windows should match the number of IP decay values in the data section.
Note, if the survey is pole-dipole or pole-pole, the station number for the remote Tx electrode can be specified using the field names C2X or T2X.

Line 3: Column names

There are no real standards on the names used for the columns in an IP data file, so there are a large range of variations which are implemented in TQIPdb to handle most of the possibilities.

Transmitter electrode fields:

First Tx electrode Transmitter line number: “C-LINE", "C1_LINE", "LINETX"

First Tx electrode station number: "F1", "C1", "XA", "C1_STATION"

First Tx electrode X coordinate: "C1X", "C1-X", "F1X", "FX1", "TX1", "T1X"

First Tx electrode Y coordinate:  "C1Y", "C1-Y", "F1Y", "FY1", "T1Y", "TY1"

First Tx electrode Z coordinate: "C1Z", "F1Z", "FZ1", "T1Z", "TZ1", "C1_Z"

Second Tx electrode Transmitter line number: "C2_LINE"

Second Tx electrode station number: "F2", "C2", "XB", "C2_STATION"

Second Tx electrode X coordinate : "C2X", "C2-X", "F2X", "FX2", "TX2", "T2X"

Second Tx electrode Y coordinate : "C2Y", "C2-Y", "F2Y", "FY2", "T2Y", "TY2"

Second Tx electrode Z coordinate : "C2Z", "F2Z", "FZ2", "T2Z", "TZ2", "C2_Z"

Receiver electrode fields:

First Rx electrode Transmitter line number: "P-LINE", "P1_LINE", "LINERX"

First Rx electrode station number: "P1", "XM", "P1_STATION"

First Rx electrode X coordinate: "P1X", "P1-X", "PX1", "M1X", "MX1", "RX1", "R1X"

First Rx electrode Y coordinate: "P1Y", "P1-Y", "PY1", "M1Y", "MY1", "R1Y", "RY1"

First Rx electrode Z coordinate: "P1Z", "PZ1", "M1Z", "MZ1", "R1Z", "RZ1", "P1_Z"

Second Tx electrode Transmitter line number: "P2_LINE"

Second Tx electrode station number: "P2", "XN", "P2_STATION"

Second Tx electrode X coordinate: "P2X", "P2-X", "PX2", "M2X", "MX2", "RX2", "R2X"

Second Tx electrode Y coordinate: "P2Y", "P2-Y", "PY2", "M2Y", "MY2", "R2Y", "RY2"

Second Tx electrode Z coordinate: "P2Z", "PZ2", "M2Z", "MZ2", "R2Z", "RZ2", "P2_Z"

Data fields:

First IP channel: "M1"

Second IP channel: "M2"

Mx chargeability: "MX", "XIP", "IP"

Decoupled phase: "3PT", "PHZ", "0IP", "PHZ(OBS)"

Total chargeabiliuty: "CHG", "M", "IP_AVG"

Apparent resistivity: "RESISTIVITY", "RHO", "RES", "RO", "APPRES", "2DRHO", "RESMEAS", "RESCALC", "RHO(OBS)", "RA"

Self-potential: "SP"

Transmitter current: "I", "TXI", "CURRENT", "IN"

Number of repeats: "CYC", "WI", "CYCL", "NSTACKS", "STACK"

Primary voltage: "VP"

Repeatability error: "SEM", "SD", "STDDEV", "ERRM"

Contact resistance: "CRX", "CONTACT"

Array type: "ARRAYTYPE", "EL-ARRAY"

Dipole spacing: "D", "DIPOLE"

Time of reading: "TIME"

Mx integration time: "VD", "V_D"

First delay offset: "MD", "M_D"

Date: "DATE"

Hour: "HOUR"

Plot point: "PLOTPOINT"

N spacing: "N", "N-LEVEL", "SPACING"

Use resistivity flag: "USERES", "RA_DELETED"

Use IP flag: "USEIP", "MX_DELETED"

VP error: "VPERR", "ARERR", "ERRVP"

Decoupled phase error: "PHZERR", "IPERR"

Window widths:
"DTIME1", "DTIME2", "DTIME3", "DTIME4", "DTIME5", "DTIME6", "DTIME7", "DTIME8", "DTIME9", "DTIME10", "DTIME11", "DTIME12", "DTIME13", "DTIME14", "DTIME15", "DTIME16", "DTIME17", "DTIME18", "DTIME19", "DTIME20", "DTIME21", "DTIME22", "DTIME23", "DTIME24", "DTIME25", "DTIME26", "DTIME27", "DTIME28", "DTIME29", "DTIME30", "DTIME31", "DTIME32", "DTIME33", "DTIME34", "DTIME35", "DTIME36", "DTIME37", "DTIME38", "DTIME39", "DTIME40"

IP data values:
"IP0", "IP00", "IP1", "IP01", "IP2", "IP02", "IP3", "IP03", "IP4", "IP04", "IP5", "IP05", "IP6", "IP06", "IP7", "IP07", "IP8", "IP08", "IP9", "IP09", "IP10", "IP11", "IP12", "IP13", "IP14", "IP15", "IP16", "IP17", "IP18", "IP19", "IP20", "IP21", "IP22", "IP23", "IP24", "IP25", "IP26", "IP27", "IP28", "IP29", "IP30", "IP31", "IP32", "IP33", "IP34", "IP35", "IP36", "IP37", "IP38", "IP39", "IP40", "IP41", "IP42", "IP43", "IP44", "IP45", "IP46", "IP47", "IP48", "IP49", "IP50", "IP51", "IP52", "IP53", "IP54", "IP55", "IP56", "IP57", "IP58", "IP59", "IP60", "IP61", "IP62", "IP63", "IP64"

"IPA", "IPB", "IPC", "IPD", "IPE", "IPF", "IPG", "IPH", "IPI", "IPJ", "IPK", "IPL", "IPM", "IPN"

"M0", "M00", "M01", "M02", "M3", "M03", "M4", "M04", "M5", "M05", "M6", "M06", "M7", "M07", "M8", "M08", "M9", "M09", "M10", "M11", "M12", "M13", "M14", "M15", "M16", "M17", "M18", "M19", "M20", "M21", "M22", "M23", "M24", "M25", "M26", "M27", "M28", "M29", "M30", "M31", "M32", "M33", "M34", "M35", "M36", "M37", "M38", "M39", "M40", "M41", "M42", "M43", "M44", "M45", "M46", "M47", "M48", "M49", "M50", "M51", "M52", "M53", "M54", "M55", "M56", "M57", "M58", "M59", "M60", "M61", "M62", "M63", "M64"

"DECAY_1", "DECAY_2", "DECAY_3", "DECAY_4", "DECAY_5", "DECAY_6", "DECAY_7", "DECAY_8", "DECAY_9", "DECAY_10", "DECAY_11", "DECAY_12", "DECAY_13", "DECAY_14", "DECAY_15", "DECAY_16", "DECAY_17", "DECAY_18", "DECAY_19", "DECAY_20", "DECAY_21", "DECAY_22", "DECAY_23", "DECAY_24", "DECAY_25", "DECAY_26", "DECAY_27", "DECAY_28", "DECAY_29", "DECAY_30", "DECAY_31", "DECAY_32", "DECAY_33", "DECAY_34", "DECAY_35", "DECAY_36", "DECAY_37", "DECAY_38", "DECAY_39", "DECAY_40", "DECAY_41", "DECAY_42", "DECAY_43", "DECAY_44", "DECAY_45", "DECAY_46", "DECAY_47", "DECAY_48", "DECAY_49", "DECAY_50", "DECAY_51", "DECAY_52", "DECAY_53", "DECAY_54", "DECAY_55", "DECAY_56", "DECAY_57", "DECAY_58", "DECAY_59", "DECAY_60", "DECAY_61", "DECAY_62", "DECAY_63", "DECAY_64"

CR decoupled magnitude values: "MAG"

CR magnitude values: "MAG1", "MAG3", "MAG5", "MAG7", "MAG9", "1MG", "3MG", "5MG", "7MG", "9MG"

CR phase values: "PHI1", "PHI3", "PHI5", "PHI7", "PHI9", "1IP", "3IP", "5IP", "7IP", "9IP"

Notes:

M1 and M2 will be interpreted as the Rx electrodes if they occur in the first 4 columns

Fields like C1X, P2Y etc will be interpreted as the relevant electrode station number if no field such as C1 or P2 has been defined

In the edited files, the M1 to M4 IP columns contain only null data, so the names have been prefixed with a “d” so that they are not imported.
The M” column has been renamed to M so that it is imported correctly

The CU column has been renamed to TxI

Line 4+: data

The data in the body of the file has the same structure as defined by the data names defined on line 3.
Load the edited data file:

1. Start TQIPdb and create a new database:
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2. Click on the Import Data> IP data> Field data menu item and select the edited data file
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3. Change the Transmitter current units to Amps 
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4. Click on the Scan file button to ensure that the data has been decoded correctly:
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5. Once the data has been verified, click on the Import Data button and select the location to store the data in the database:
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Note that the node names are purely descriptive. If you desire, you can select an existing node and use the New Child Name text box at the bottom of the form to add a new node to the list. The data imported will be added as a new node below the selected one with the name Line appended at the start of the line number defined in the IP data file (in this case the name will be Line 7900N).
6. Once the data file has been imported, the process can be repeated for any other IP data files by selecting the other data files at the bottom of the import form. Once all data has been imported, click on the Done button to return to the main database form. Then select the line number in the node lit at the top left to display a simple pseudosection for the selected data value:
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7. The colour ranges used for displaying the pseudosection can be changed using either the Database> Program Defaults/Data Ranges menu item or the middle button in the pseudosection navigation panel. Once the Program Defaults form is displayed, click on the Psuedosection tab and then click on the Set All Limits button to fill in the data limits using the data stored in the database. You can also set the limits manually by entering the required values.
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8. Use the dropdown list at the bottom right of the form, change it to Chargeability and then click on any point in the pseudosection to display the IP decays at that point.
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9. Click on the Output Data> IP/EM data menu item to bring up the Output Data form and select UBC IP2D as the format:
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10. Click on the Data Selection tab, select the line number for the data to be exported and click on the Output Data button to perform the export. Note that the line number will be used to construct an output folder name as the “Output each line to a separate directory” option is turned on. Also a batch file to run the inversion will be created at the same time.
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11. Once the inversion has been run, you can import the inverted data into the database and store it with the observed data to allow direct comparison of the observed and inverted data. To do this, close the Output data form and click on the Import>  UBC Inversion Data> 2D Observed data and select the vp and ip observed data files. The Import IP Data File form will then be displayed. If the inversion data was written out using the same TQIPdb database, you can then simply click on the Import Data button and select Yes when prompted to allow use of the location lookup table. If the data was created outside TQIPdb, you need to specify the receiver line number before importing the data. And you will also need to specify a node in which to add the data. If you select the node from which the data was exported (in this case Line 7900N), then just the error and modeled values will be added to the observed data records. If you select a different node, then new data records will be added to the database to hold the data. 

12. After the observed data has been imported, repeat the process for the inverted data. Once the observed and imported data have been imported, you can then view the modeled data and data misfit as pseudosections and identify problem data and modify the error value for that point or turn off the IP or resistivity data to exclude it from the inversion altogether.
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13. Once the inversion has been run to your satisfaction, you can create presentation plots of the results by importing the UBC inversion files into WinDisp. To do this start WinDisp, double click on the Start New Layout in the Current Directory option and click on the Utilities> Import UBC/Zonge IP inversion files menu item and then select the dcinv2d input definition file:
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If the input file uses standard naming conventions, the remaining fields will be filled in on the form. If any file is missing and needs to be included, you can select them manually by clicking on the file selection button at the right of the missing file name.

Also, if a second depth of investigation inversion has been run, click on the Depth of Investigation Files tab, select the required files and specify the desired DOI cutoff value.

14. Once all files have been selected, click on the Generate Grids and Layouts button, specify the output data file name (which will be a Geosoft dat format). The program will then inform you of some details of the data that has been read and ask you to specify the plot scale to use for generating the pseudosection layouts. In this case use a scale of 5000. The inversion data will then be gridded and contoured and a number of file layouts will be added under the File menu item on the WinDisp form. The first will be of the form *\Line_7900N\7900N.csf and defines a layout displaying the basic observed resistivity and chargeability pseudosections:
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The next layout created is of the form *\Line_7900N\7900N_ubc\7900N_err.csf and defines a layout which displays the observed, modeled, % error and Z-score error images for resistivity and chargeability:
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The next layout created is of the form *\Line_7900N\7900N_ubc\7900N_mod.csf and defines a layout which displays the observed, modeled and inverted model images for resistivity and chargeability:
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The final layout created is of the form *\Line_7900N\7900N_ubc\7900N_inv.csf and defines a layout which displays the observed data and inverted model images for resistivity and chargeability:
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Exercise 2: Loading multiple IP data, data editing and thresholds 

1. Start TQIPdb and create a new database named peanut.mdb in the peanut folder. Then click on the Import Data> Field Data> IP data menu item and select the file L10000N.dat. Select mAmp as the Tx Current Units and scan the file to ensure that the data is being interpreted correctly. Then click on the Import Data button and save the data in the Dipole-dipole Data node. 
2. You can repeat this process for each of the remaining files. But if all files have the same format and none of them need to have either a Tx line or Rx line specified on the import form, then you can use the multiple file selection option to select all of the data files that are to be imported:
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3. When you click on Open and then on the Import Data button, all of the selected files will be scanned and imported and the number of points imported for each file will be reported. Once all of the files have been imported, close the Import Data form, click on Line 10000N in the database tree list and select Mx as the data to display:

[image: image20.png]. IP DATABASE peanut. mdb
Fie Database ImportData OutputDeta CurentNode Help

[Dipole-Dipolis data for Line 10000N ¥ Use Data

¥ Use Resistivity
g Revised [18-Feb-2009 I~ Validated Validate Line % usep
Line 102000 < [ Reset
Line 104000
Line 106000
Line 103000
Line 11000
Line 112001
Line 114000
Line 16000
Line 113001
Line 12000
Line 122001

T0310.2 00771 Hide plotpoints |~ Show inks |

vew [P <] |Pelmar Msfia s Aenf MxEn |-
Coos [fosaiGid =]
Ay [poieDipels =]
o [fmebomanzle =l
Axtine [iooon =]
Tx Line ,m

Sense [all 3

L
I Elevation
Show File List o —





4. Click on the dark blue data point and observe that the decay plot looks reasonable, but appears to have a negative DC shift:
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5. The simplest thing to do with this value is to turn it off so that it not used when outputting the data from the database. To do this click on the Del key (clicking on it again turns it back on). Alternatively, clicking on the number key corresponding to the repeat to be turned off (in this case 1) also toggles the IP value. Another option is to click on the repeat checkbox at the right of the decay plot. Still another option is to doubleclick on the Mx value in the repeat plot at the left of the station repeat value grid below the decay plot. Finally, the F1 and F2 keys can be used to turn all IP repeat values on and off. The defined keycodes can be displayed by clicking on the Help> Keycodes menu item:
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6. If you think that the decay is actually reasonable apart from the DC shift and want to edit it so that it is included when the data is exported then simply hold the shift key down, click on a point on the decay plot and drag the decay up or down to achieve the desired DC shift. As the decay is moved up and down, the updated Mx chargeability and total chargeability values are displayed next to the cursor and the updated average value is displayed in the section profile:
[image: image23.png]. IP DATABASE peanut.mdb
Fie Datobase ImportData OutputDate Current Node  Help

Pole-Dipole Data
Dipole-Dipole Data
Line 100001
Line 102001
Line 104001
Line 10600
Line 102001
Line 110001
Line 112001
Line 114001
Line 115001
Line 112001
Line 120001
Line 122001

Pole-Pole Data
Gradient Data
Inversion Data

TEM Data

| Average
Repeats
Show All

Scale
Raw
Markers

ez

[a331

(2085

Coorts [losaibid ]
ooy [opoedpos =
Twe  [Tmebomanzle =
Rutine [roooN <]
Tetne [ooon =]

Sense [l E

Cont [g3
Show File List

Res [603.56

W [7.92

50 [0.0000

Res Ex -

WaEn -

_/\’/I/\/\/\

sela

Srerel

B
ol
vatfic

Fit Decay

I~ Elevation
M -





7. Once you have the DC shift at the right level, release the mouse button and the display will be updated with the shifted decay. At this time, the edited decay is only held in memory, so if you click on a different line or close the database, the edited values will not be saved. To save the edited value, click on the Save button that will be displayed on the form. Clicking this button saves all pending edited decays for the current line, so you can defer saving the edits until you have made all of the required modifications. If you have saved an edit, but want to revert to the original decay, click right on the edited point and either click on the Clear decay edits button to reset the currently selected repeat or on the Clear all decay edits to reset all edited repeats for the current location. Further, to locate edited points for the currently displayed line, changed the variable to be displayed to Num edited and those locations which have edited decays will be highlighted on the pseudosection. Finally, to reset the edits for all points of the currently selected node in the tree list, click right on the selected node and select the Recalculate> Revert to raw decay data from the pop-up menu. (Note this is the same as selecting the same menu item under the Current Node menu item on the main database form).

8. One of the simplest ways to review the data for the currently displayed line is to click on the left-most point to display the decay and then use the right arrow on the keypad to scroll through the data for the same n-level, turning off bad decays as they are encountered. When you reach the right-most point for the current n-level, pressing the right arrow key takes you to the left-most point for the next higher n-level.
9. Another simple way to quickly cull bad data values is to use one of the threshold options available by right clicking on the currently displayed node in the display list and selecting Threshold from the pop=up menu eg applying the Negative Mx option after editing bad decays for line 10000N yields the following pseudosection:
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10. Working through the UBC2D output process described above yields the following inversion model:
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The resistivity model shows good agreement with the observed data, but the chargeability model has encountered problems due to the low chargeability value at 10675, n=6. Inverting the modified data using UBC2D gives the model:
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While inverting the same data using res2dinv results in the following model:
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Exercise 3: Loading station locations and elevations 

1. In the previous exercise, the data were collected in an area containing significant topography and where the lines deviated substantially from the simple layout implied by the Line/station plan view. In order to use the topography and actual coordinates in the inversion, it is necessary to load the required information into the database. The data files containing this information comes in a wide variety of forms: the files may have any mix of line, station, map coordinates and elevations and the information may be separated into a number of different files. For this survey the required information comes in two files. The first (GPS_Peanut.stn) contains the Line/station coordinates used for collecting the IP data together with the actual map x/y coordinates collected using a GPS meter. To import this data, click on the Import Data> Locations menu item, select the GPS_Peanut.stn file and change the First data line to 2 and the column names value to 1. In this case all of the data columns have been correctly identified, so click on the Scan Data File button to ensure that they are being decoded correctly and then click on the Import Data button to load the data into the database.
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2. To see the actual layout of the survey in map coordinates, click on Done to return to the main database form and then change the Coords selection to Map Coordinates (change the View option to Plan if it is not already the selected option)
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3. The topography data for this survey is provided as an xyz data file (exported from a grid file) and has columns for the map x/y coordinates as well as a topo column. To import this data, click on the Import Data> Locations menu again, select the file Peanut_DEM_UnCompressed.xyz and set the first data line to 2 and the name line to 1. This data file does not have the line and station coordinates, so change the Location Import Style drop-down to File does not include Line and Station values and then change the X,Y and Elevation columns to their obvious values. Click on the Scan Data File button to check that the data has been defined correctly and then click on the Import Data to load the data into the database.
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4. To see the topo data, return to the main database form, select one of the data lines in the tree list, change the View to Plan and the Coords to Map coordinates and the elevation locations will de displayed as coloured dots;
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5. Now that the topo data is available in the database, exporting the data to UBC2D format as before and importing it into WinDisp yields the model:
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The res2dinv inversion of the same data yields the model:
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Exercise 4: Inverting multiple lines
When there are multiple lines in the database that need to be inverted, simply set up the required inversion format on the output form. Then select the All Lines item in the Line Number list, ensure that the “Output each line to a separate directory” checkbox is turned on and output the data. Each line will be written to its own folder and a batch file which runs the inversion process for each line output will be created in the folder which was selected on the Output File Location tab. The inversions can then all be run by starting the main batch file.

Unfortunately, the process for converting the inversion output to create useful displays has not yet been automated, so each line needs to be manually converted, but the process is reasonably rapid with only a small number of button clicks required.
Once all of the inversion files have been created, you can display and print each of the required inversion layouts. Once you have set up the required information for the first layout, the same information can be loaded into the remaining layouts using the File> Read Component menu item and selecting just the elements of the main layout which should be added to the current one. Further, when printing layouts to a pdf file, the layouts for subsequent lines can be appended to an existing pdf by selecting the existing file and selecting Yes when asked if you wish to append the current output to the existing file.
Another useful display that you can generate when you have multiple inversions is a multipanel plot showing the inverted resisitvity and IP inversions. To do this, start a new WinDisp layout and click on the Edit> Multi-panel display menu item. 
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Double click on the first line in the list (or click on the first line and then click on the Define Panel Contents button) and then click on the Image and Topo tab.
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Double click on the Image File textbox or click on the File selection button at the right of the text box and select the northernmost inverted resistivity model:

[image: image36.png]Image File

Fll name: [1220000s o ot
Flescftpe: [image Fes (g4~ b1 bp)





Set the Invert Colours option, click on OK and then on Done, specify 10000 as the plot scale and click on Display! to see the first inverted resistivity image:
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Click on the Edit> Multi-panel menu item to return to the Multple Panel Display definitions form. From here you can manually add the remaining grid files as above. Alternatively, open a Windows Explorer window and successively drag the required images onto the Panel list:
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Double-click on the first line in the list, click on the Image and Topo tab, click right on the Invert Colours check box and all panels will the be set up to display the images using a red to blue colour stretch. Click on the Area limits tab, change the MinimumX value to 10000 and click right on the Minimum X label to copy the changed value to all of the defined panels. Repeat this fot the Maximum X, setting it to 11500 and also the MinimumY, changing it to 500. Click on Done and then Display!
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Repeat the process and add the IP inversion grids to the panel definitions. Here, you should add the first IP file and then modify the Image display style to turn off the Invert colour and histogram equalization checkboxes and also change the Column to display the image to 2. Then these same setting will be applied when you add the remaining IP inversion image files. Once all of the images have been added, double click on the first panel and copy the display limits as before as the newly added IP inversion files will still have the actual grid limits.
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The inverted image files have been generated using the Line/station coordinates from the IP data files. This is often adequate when the IP lines run EW or NS. For this survey, the lines are running in a north-easterly direction, so it is difficult to identify the real location of anomalies in the models. When the IP inversion files were written out of the database, two extra files with the extension sct were also created along with a station definitions file and these can be used to display the true map coordinate in the plot. The station file contains the station number along with the map x, map y and elevation coordinates. This can be manually loaded in by clicking on the Define Oblique Baseline Definitions button on the Area Limits tab and then selecting the station file using the Load Baseline Profile file button. 
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However, a simpler way is to simply drag the sct file from the Windows explorer window onto the Multi-panel display list and all of the definitions will be loaded. When the images are displayed, the x axis of the grid file will be converted to actual map coordinates on the display and the easting and northing coordinates will be displayed.
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Exercise 5: Displaying the inversions in 3D
Displaying the inverted IP models in 3D with other data provides a powerful mechanism to visualize the data and to help analyse structure. The sct files used in the multiple panel display can also be used to quickly construct a 3D model displaying the inverted sections. To do this, start the 3DModeller form by clicking on the 3D Models menu item:
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Click on the 3D Files tab:
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And then click on the Section Grids tab.
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Then drag the sct files from the Explorer window and drop them on the list:
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Next, double-click on the first line in the list to display the Section Grids Definition form:
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Click on the Display Definitions tab, turn on the Invert Colour and Histogram Equalise check boxes and click on the Copy To All button (or click right on the checkboxes and click on the Copy to All popup menu).
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Next click on the Baseline Definitions tab and change the Bottom grid value to 400 and the Top Grid value to 1200 and click right on the labels to copy the definitions to all the other sections.

[image: image49.png]. Section Grid Definitions

[StatGid  [10000.0

[End Grd

[iT500.0

[Cine Azt [47.4

[Batom Grd 100

[Top Grid

fra00

[Start East— [3683.1

[Start North

[i6iz08

[Elevation st Top [675.8

Transform Coords |  Reset Coords

Baseline File [[ine_0000N stn

| Profi Coord [ s Station rumber =l

Station Number [7

First data line [3

Read Increment [7

Clip above [0

Xeoumn 2

¥ column

Z column

[ GidYis depth [

Stn
10000.0
101000
102000
103000
1040000

Gridl

16120
16188
16256
16324
16350

K
RooxFRile [ | Linecoouw [ Export DXF

Image Fies

1

Display Definiions

1 e

1 Inverted resstiviyfor 10000N

Cancel Done





Click on Done to close the form and then click on the Start 3DViewer button. The program will then work out the volume limits covered by the section grids and prompt you to specify a World plot scale. This is just the same as a usual 2D plot scale and you should choose a scale that keeps a balance between the displayed size of your real world objects and the sizes of graphic items such as labels.
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The form displays the ranges of the real coordinate limits in transformed usits. Keeping them in the range of about 20 to 100 generally makes the text readable and the objects clearly visible.
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One deficiency with the display just created is that each section grid is coloured individually. In this case, the resistivity range for all of the sections is quite similar, but this is generally not the case. One way to overcome this is to close the 3DViewer, return to the Section Grids tab and then click on the Section> Build Histogram from Section Grids menu item. Specify and output folder and file name (eg res_all.hst) and a histogram of all of the section grids which are not turned off will be created. Then double click on the first section line, click on the Display Definitions tab, select the histogram file and click right on the label to copy the selected file to all of the other sections. Click on Done and then on the Start 3D Viewer button and the images will now be displayed using a uniform colour scheme.
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For greater control over the colour display, return to the main WinDisp form, click on the Edit> Multi-panel display menu item, double click on the line for 11600N, click on the Image and Topo tab and then on the Edit Image button to bring up the Image File Specifications form:
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Next, click on the Display Histogram button to display the data distribution for the resistivity for this line:
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Change the minimum value to 250, the maximum value to 2000. Then change the Histogram distribution to Log and click on the Update Histogram button:
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Next click on the Histogram Options> Save Histogram and save the histogram file using a name which indicates the distribution used eg res_log_250_2000.hst.

Close out of the multipanel definitions form, return to the Sections grid definitions on the 3DModeller form, select the histogram file you just created and copy it to all of the sections and start the 3DViewer again.
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The section grids are very useful for seeing the detail of the 2D inversions, but they can also restrict the visibility of other 3d objects, especially when IP lines are close together. When there are multiple IP lines which have reasonable continuity of structures between the lines, it is possible to convert the loaded sections into a 3d model. To do this, return to the 3DModeller form and click on the 3D Gridding> Sections menu item, specify a name for the model you wish to create (eg peanut_ubc2d.res) and the 3D gridding form will be displayed:
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Change the Horizontal search radius to 250, turn on the Maintain Data positivity checkbox and set the Gridding Azimuth to -45 and click on Done to start the gridding. Note that the gridding method used is simply multiple stages of 2d gridding (one for each layer of cells in the model), so it works best when the structures  are continuous between the lines. If there is severe topography, the resulting model can tend to fill in the valleys. Such infill can be removed by loading the topo grid file on the Topography tab and then using the Edit > Mask model using topo> Specify value above topo and setting the data value as -99999 to null the false values. Also, the topo grid can be defined before the data is gridding and then the Grid relative to topo checkbox turned on when the gridding is performed.

 Once the gridding process finishes, the mesh and model files generated are written out and then loaded onto the 3D modeler form. Once this happens, click on the View Model tab, change the Section to View to Elevation Depth Slice and use the scrollbar at the right of the display window to scan through the depth slices. 
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Then set the isosurface value to 1200, change the minimum value to 250, the maximum to 2000 and click on the Create New 3D Oblect menu item and you will be prompted to specify a name and location for the new object:
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Change the Parent name to UBC2D and change the Name of the object to 1200 and click on Done and the isosurface will be added to the model Repeat the process with isosurface values 800 and 400
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Click right on the display lis, select Create a new Node form the popup menu and create a new node unser the UBC2D node and name it Resistivity isosurfaces
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Expand the UBC2D node, select each of the isosurface nodes and drag them onto the Resistivity Isosurfaces node. Also drag the Sections node and drop it on the UBC2D node:
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Then click on the File> Save Model menu item and save the binary model. Return to the 3DModeller form and also save the definitions used to create the model by clicking on the File> Save Model Layout.

Exercise 6: Running 3D IP inversions
The same IP data that was exported to UBC2D format can also be combined into a single UBC3D inversion. Start up TQIPdb and open the BC Gold Peanut Grid database and click on the Output Data> IP/EM data menu item and select UBC IP3D as the output format. Specify ubc3d_local as the Directory name in which to write the data. When the data is written out, the target misfit values can be specified in a number of ways. These options are displayed in the Inversion Errors part of the first tab on the output form. The database does not contain any target misfit values (although they can be assigned using the Current Node> Assign default errors menu item on the main database form). Since the chargeability values are quite low, the main modification that is required is to lower the IP error floor value from the default value of 1 to a more meaningful value of 0.1. 
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Click on the Data Selection tab and select All Lines as the Line number, set the X and Y mesh values to 50 and the elevation mesh to 20 and turn on the Output electrode elevations checkbox.
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Click on the UBC options tab, change the Regularization mode to User defined and the Chi factor to 0.01. Change the initial and reference resistivities to 1000 and the length scales to 200.
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Click on the IP Inversion tab at the right and change the initial and reference chargeabilities to 2 and the length scales to 200.
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With all of these values set, click on the Output Data button and the program will load the selected data and construct a mesh for running the inversion which is displayed on the Mesh Definitions form:
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The X and Y mesh setting are ok, but the Z mesh is probably a little to shallow. To change this, click on the Z Mesh tab and click on the Padding Definitions button:
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Change the Start of the core mesh to 500 and then click on the Apply Changes button to rebuild the Z mesh. You should see the number of Z cells change from 24 to 38. Once the mesh definitions are acceptable, click on the Continue button and the UBC inversion files will be written out. A batch file is also created and the inversion can be run by launcing it from a Windows explorer window.

Once the UBC3D inversion has been run, the resulting model can be loaded onto the 3DModeller form and the model displayed on the View Model tab. When loading the dcinv3d.con file, the model type is automatically recognized as conductivity. If you want to view the model as a resistivity model, select the mesh and model file and then change the model type to Resistivity (Inverted) before clicking on the Load model button.
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Click on the View Model tab, change the Section to View to Elevation and scroll through the model to check that the inversion has generated a reasonable model.

[image: image70.png]= 3D Model
Fle Create 3 Grddng Edt Display Hep

ffra7s = st S

Sectionto view  [Elevation Dopth Stics ~| Elevation 8500 X Clip Limits [2

Isosurface value [1214.02 Blue [2736099 Red [2154.43 Y Clip Limits |2% ]2

Smooth model [~ Grid cell split |1 Colour style ~] Invert Colour [~ Z Clip Limits [0 [

TRl s T D] View Model

- -





Since the model was created from the local grid coordinates, it cannot be directly loaded into the 3D model created from the 2D inversions. It is however possible to transform the model using a 2-point transform so that the model can have something close to real map coordinates. To do this, click on the File> Export> Transformed UBC model and specify a name for the exported model eg Peanut_local_transf.res, you then get prompted to specify if you want the padding cells included in the export. Generally, there is little useful information in these cells, so answer No. You then get prompted to specify a 2-point transform to convert the current model coordinates into the desired coordinate system. Click on the Load Transformation from File button, navigate to the peanut folder and select the transf.crd file. This coordinate transform is intended to convert from map coordinates to local coordinates, so click on the Invert button to set up the required local to map transform. Then click on Done, change the output cell sizes to 50, click on Done, respond Yes to maintain positivity and the model will be exported. Load the transformed model, then start the 3D Viewer and open the previous 2D model and then add a 1200 ohm.m isosurface from the ubc3d inversion, turn off the 2d sections and the other isosurfaces and the model should look like this:
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Clearly the cross-line smoothing constraint (200) is not large enough as there are strong features along the lines. 

The local coordinate grid represents an idealized view of the actual survey, and the real electrode locations can potentially deviate significantly from the desired constant station separation and constant line spacing. If the deviations are large enough that they may be affecting the inversion, the ubc3d data can be exported using the actual map coordinates instead of the local coordinates. This is achieved by selecting the Map coordinates option in the Coordinates drop-down list on the Data Selection tab. If you then click on the Area Selection tab, you can see that the lines do deviate from the ideal, but the spacing is generally quite reasonable. However, if a ubc3d inversion was created using these coordinates, it would be quite inefficient as the mesh must be rectangular in the coordinate space, so there is a significant part of the mesh outside the coverage of the data. 
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To remedy this, click on the Define Output Coordinate transform button and select the transf.crd transform file. When you click on Done, the transform is applied to the locations and you can now see that the area covered by data is almost rectangular, so the resulting 3d mesh will be much more efficient. Go to the Data Selection tab, turn off the Move electrodes to nearest node option and click on the Output Data button and proceed as described before.

Once again, the model cannot be loaded directly into the existing 3d model, so export a transformed model using the transf.crd, invert the transform, export the model and load the exported model. Open the 3d model created above and add a 1200 ohm.m isosurface to the model. Again, the 3d inversion has strong line effects, so the y length scale is too small, but the agreement between the isosurfaces is quite good.
